Community
Arnold GPU Forum
General discussions about GPU rendering with Arnold.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Difference between Arnold GPU and CPU rendering

15 REPLIES 15
Reply
Message 1 of 16
yogeshsherman
2477 Views, 15 Replies

Difference between Arnold GPU and CPU rendering

I am facing issue while I am rendering Fur with Arnold CPU everything works fine but the moment I changed it to GPU it renders Fur with any textures and takes longer time than CPU. I am using RTX 2070 with Ryzen 3700x with Arnold Version 4.4.1.

Please let me know what I am doing wrong.

15 REPLIES 15
Message 2 of 16

So far no one even tried to check if I am right or wrong , Very Sad

Message 3 of 16

Can you post Arnold logs (verbosity level Detailed) for CPU and GPU renders, so we can see what's happening?

When you say GPU takes longer, are you allowing for the GPU pre-population time?



// Stephen Blair
// Arnold Renderer Support
Message 4 of 16

Also GPU render image with fur is darker than CPU render image with fur .I'll post Arnold log soon

Message 5 of 16

Message 6 of 16

I am not using Maya Hair Shader, I m using Arnold Hair Shader not even Al hair shader, I have used it with Houdini Fur

Message 7 of 16

There's no "Maya Hair" shader, whatever the user did in Maya, it ends up as an Arnold hair shader.



// Stephen Blair
// Arnold Renderer Support
Message 8 of 16

There is no link to Maya here, I am using Arnold hair shader with Houdini Fur just to make it easier for understanding

Message 9 of 16
thiago.ize
in reply to: yogeshsherman

Did you try increasing the global specular ray depth? While that solution might have been in the maya hair shader arnoldanswer that Stephen linked to, that should also apply to Arnold hair shader since under the hood it's all the same.

Message 10 of 16
yogeshsherman
in reply to: thiago.ize

@Thiago Ize I am using Houdini and your solution isn't logical why should I need to raise ray depth while using GPU when CPU is rendering fine, Maybe I am wrong

Message 11 of 16
thiago.ize
in reply to: yogeshsherman

Because the GPU code path doesn't yet support the extra_depth param on the hair shader, so you need to globally increase the specular ray depth. Please give it a try.

Message 12 of 16
yogeshsherman
in reply to: thiago.ize

I raised the specular ray depth to 64 as suggested by you to 64 just to see if it is working but it is not working and I think Solidangle knew about it too

Message 13 of 16

How would check verbosity when on GPU it totally disregards the texture and renders with plain color

Message 14 of 16
thiago.ize
in reply to: yogeshsherman

Just to be clear, this didn't make your gpu fur less dark? Or are you referring to the missing texture issue, which yeah, the specular depth has nothing to do with. At this point I think it'll help if you post a comparison cpu/gpu image so that we're all on the same page. Complete logs with stats could also help.

Message 15 of 16
aaronc8X89K
in reply to: thiago.ize

I know this thread is old, but I hit this issue and tried increasing Render Settings > Arnold > Ray Depth > Specular to 16, and it didn't make any difference. Any other ideas?

Maya 2023, MtoA 5.3.1.1 - 6e67ae93 (fix-5.3.1) .
Message 16 of 16

Please show some images and your settings.

----------------------------------------------------------------
https://linktr.ee/cg_oglu

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums