Community
Arnold General Rendering Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Random Walk SSS Bug Fix?

6 REPLIES 6
Reply
Message 1 of 7
Anonymous
734 Views, 6 Replies

Random Walk SSS Bug Fix?

Will there ever be a fix for the Random Walk SSS? I've been waiting for months and it's still the same depth limit "bug" since then.

There are some others who have already reported the bug here.

Thanks.

https://answers.arnoldrenderer.com/questions/7832/view.html

Labels (3)
6 REPLIES 6
Message 2 of 7
Stephen.Blair
in reply to: Anonymous

The minimum radius is clamped to avoid the problems that happen with loss of precision with really small values. Similar problems happen if you're really really far from the origin. This is a limitation of floating point precision, so unless we can come up with some alternative approach or tradeoff, the clamping stays.



// Stephen Blair
// Arnold Renderer Support
Message 3 of 7
Anonymous
in reply to: Anonymous

Hey Stephen.

It's a shame to hear that. I can remember it worked in early releases. Maybe it was wrong in some way, but there was a result. The only way to get something useful is to scale up the whole scene. (Not really a solution for complex setups...).

Its one of the features that makes Arnold so unique compare to others engines. I hope there will be some improvements.

Thanks for your feedback.

Message 4 of 7
daniel
in reply to: Anonymous

The default export scale in C4D is set to 1 meter, yet it needs to be set to 0.01 meter to honor the internal default dimensions withing c4d. The sss density scaling works fine enough then, so its no bug.

Message 5 of 7
Anonymous
in reply to: Anonymous

Hello,

is there a chance of actually documenting this limitation? Obviously, quite a few people run into this, e.g when rendering thin features like flowers, leaves (which might have thickness for a closeup).

The only way to find out it exists right now is to google exactly the right terms and arrive here and a few other places.

Message 6 of 7
thiago.ize
in reply to: Anonymous

We were able to further improve this limit in Arnold 5.3 (released a couple months after the initial problem in this post was reported). Are you still seeing issues in 5.3 or newer?

Message 7 of 7
Anonymous
in reply to: Anonymous

How can I fix it this bug ?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums