Community
Arnold General Rendering Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Imagers prevent IPR refresh

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
dbradham
454 Views, 3 Replies

Imagers prevent IPR refresh

I have an annoying issue that persists across Houdini and maya. When I add any imager to my scene, ipr refreshes become very infrequent. I can get an immediate refresh in the render view in Houdini or maya by toggling any imager on and off. It doesn’t matter what type of imager it is, they all exhibit this behavior for gpu or cpu rendering. As such I’ve bound hotkeys in each software to toggle an imager and I just have to tap that hotkey to get the latest image to appear! Any ideas? Definitely feels like a bug.

3 REPLIES 3
Message 2 of 4
thiago.ize
in reply to: dbradham

It could be due to imagers not running very often. You can control the frequency with which imagers are run by using options.imager_overhead_target_percent. It defaults to 1, which means imagers are run so that they only introduce about 1% overhead. So if you raised that value you'll get imagers being run more often. Try 10, or 50, or 10000 to see if that solves your issue, though of course the higher you go the slower your render might become as imagers get run more often.
In houdini you can do this by adding *ar_imager_overhead_target_percent* (note the ar_ prefix) as a float spare param on your Arnold ROP. We have HTOA-2406 for exposing this in the Arnold ROP.
Message 3 of 4
dbradham
in reply to: thiago.ize

Ohhh fascinating. Thank you @thiago.ize I’ll let you know how it goes.

Message 4 of 4
dbradham
in reply to: dbradham

That worked great @thiago.ize. Thank you. I found a value of 5 or 10 increased responsiveness without sacrificing 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report