Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Z-depth is incorrect in large scene (Unidentified round line noise)

2 REPLIES 2
Reply
Message 1 of 3
t-seike
152 Views, 2 Replies

Z-depth is incorrect in large scene (Unidentified round line noise)

In very large scenes, the Z AOV is displaying incorrect information.

In the attached image, circular artifacts are visible on the rendered plane.

Z-depth_banding.png

Version info:

Maya 2023.3

Arnold Core 7.1.3.2

MtoA 5.2.1.1

 

Steps to Reproduce:

  1. Open Maya and load mtoa plugin
  2. Create plane from Polygon Primitives
  3. Scale up the plane to 33000000 for each xyz axes
  4. Create camera
  5. Set Camera Translate to [3700, 190000, 1500000]
  6. Set Camera Rotate to [-2.5, 8.5, -0.4]
  7. Set Camera Focal Length to 60
  8. Set Camera Far Clip Plane to 10000000.000
  9. Activate Z AOV in Render Settings
  10. Set Camera to Renderable Cameras
  11. Set Image Format to exr
  12. Take a Render Sequence
  13. Check output Z image in AfterEffects
  14. Apply ExtractoR effect and set Channel to Y, set White Point to 10000000
  15. The problem should be reproduced
Labels (2)
2 REPLIES 2
Message 2 of 3
t-seike
in reply to: t-seike

My previous post simply listed facts and steps, but now I'm seeking solutions to address this issue. The provided example was generated while simplifying a complex scene; the actual problem arises within an even more intricate setup.

Message 3 of 3
joie
in reply to: t-seike

I faced that very same problem with ZDepth and Position passes.

I found there is a limit on the accuracy. In my case it was a very large scene, but the real problem was that it was WAY too far from the origin (came from CAD). So, you can change and offset the origin of your scene in the render settings.

If that doesn't work (it didn't for me), I finally had to create a custom AOV and then plugged a flat shader to it with a samplerInfo node connected (camera position) so I get camera ZDepth, although there are several methods to do that.

The trick is to MULTIPLY the result of that shader by, let's say, 0.0001, so you are reducing the range of the ZDepth so MtoA can process it correctly.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report