Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MTOA channel packed textures problem

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
Shyralon
1160 Views, 10 Replies

MTOA channel packed textures problem

Hello everyone!

I have a problem with using channel packed textures in Maya-Arnold.

Essentially I have three masks packed into the rgb channels of a texture.

When loading a single channel to extract a single mask, I get a weird result where darker parts of the other channels are still in the masks. Looks like a weird version of luminance or desaturated image. I would expect to get a clean mask as it is in Photoshop for example.

8334-arnold-rgb-problem.jpg

Left is the packed texture and the individual channels in Photoshop. Middle is my test shader and right is the result when extracting one of the masks. This happens with all my channel packed textures coming from quixel/substance, not only the test image.

Using Maya 2019 with the latest Mtoa (4.0.4.1 with Arnold Core 6.0.4.1) and ACES 1.0.3 as colorspace (not sure if that is relevant tho, also happens without aces)

Would really appreciate any help on this issue.

Tags (3)
Labels (3)
10 REPLIES 10
Message 2 of 11
lee_griggs
in reply to: Shyralon

Could you upload the texture map, please?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 11
Shyralon
in reply to: lee_griggs

Yes, of course!

I attached the test texture and a simple project where the problem occurs.

Thanks for your help!arnold_rgb_test.zip

Message 4 of 11
Anonymous
in reply to: Shyralon

No problem if you extract the Red & Green channel with the Shuffle Node, you get a clean mask. The only problem is with the blue Channel

Message 5 of 11
Shyralon
in reply to: Anonymous

Just tried with the shuffle nide again, but could not manage to get a clean mask for any of the three channels by negating the remaining two channels 😕

Message 6 of 11
Anonymous
in reply to: Shyralon

Work fine here Just put Specular Weight to zero

8353-blue-mask.jpg8351-redmask.jpg8352-green-mask.jpg

Message 7 of 11
lee_griggs
in reply to: Shyralon

Is your texture set to RAW?

8307-1602073124820.png

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 8 of 11
Stephen.Blair
in reply to: lee_griggs

The test scene had Use Existing Tx turned off



// Stephen Blair
// Arnold Renderer Support
Message 9 of 11
Shyralon
in reply to: Anonymous

That fixed it! I was using the shuffle node, but only clicked the "negate channel" for the other two channels. When I explicitly put the Green and Blue to "alpha" as you did I get a clean mask 🙂 Don't exactly understand why, but it works, so thanks a lot!


Message 10 of 11
Shyralon
in reply to: Stephen.Blair

Thanks a lot for your replies! Both raw or utility-srgb-texture as well as use existing tx on and off gave the same results for me. But it is working with the answer below with using an aishuffle node.

Message 11 of 11
Stephen.Blair
in reply to: Shyralon

With Use Existing Tx turned off, it was the color management that was the problem.

With all the things I tried changing, I also changed the color space on the file node, but I forgot about that. That's why I didn't repro the problem (except just once)



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report