Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya Arnold 7 USD Instanceable Not Rendering

3 REPLIES 3
Reply
Message 1 of 4
bryce.gattis
770 Views, 3 Replies

Maya Arnold 7 USD Instanceable Not Rendering

Hi all,

Curious if anyone is able to replicate this issue. It's a massive issue for us as we can't update to Arnold 7 without figuring out why our instanceable objects no longer render.

Describe the bug
Latest build of MtoA (5.0.0.3) with Arnold Core 7.0.0.2 seems to be unable to render prims if they are marked as USD Instanceable. Both prims with composition arcs (in this case Referencing) and prims with no composition arcs seem to be affected by this issue. Upon checking the USD Instanceable checkbox in Maya on the top level prim and saving the scene, the prims disappear from the Arnold render in Maya.

To Reproduce
Steps to reproduce the behavior:

  1. Open the attached Maya file, this will have the USD file loaded as a stage.
    arnold7_instanceable_bug.zip
  2. Please be aware the reference path the cube.usda will be mapped to D:/arnold7
  3. Open the Arnold RenderView and render the scene.
  4. Observe that both of the instanceable cubes are missing from the render.

Expected behavior
I expect the USD Instanceable Prims to render in Arnold.
1645665029125.png
1645665033847.png

Used Software Versions

  • Arnold: 7.0.0.2
  • MtoA: 5.0.0.3
  • USD: 0.21.8
  • MayaUSD: v0.13.0
  • OS: Windows 10

Additional context
In the Maya script editor, I have sometimes seen this error appear:

// Error: [usd] Failed to open file () //

Associated issue:
https://github.com/Autodesk/arnold-usd/issues/1033

Tags (2)
Labels (2)
3 REPLIES 3
Message 2 of 4
bryce.gattis
in reply to: bryce.gattis

@Stephen Blair, @Sebastien Blaineau-Ortega,

Any thoughts?

I would like to note, that removing the usd_cache_proc.dll file from the %ARNOLD_INSTALL_LOCATION%/extensions/usd/2108 (in a Python 3 context of 2022) seems to make the instanceable objects render again in Maya with no errors.

Message 3 of 4

afaik, this is the same bug that is supposed to be fixed with https://github.com/Autodesk/arnold-usd/pull/1025

I had another report of the same thing. But with the latest Maya USD, it looked like this:

00:11:04  2426MB ERROR   |     [usd] Cache ID not valid 9223005 
00:11:04  2427MB WARNING |     [ginstance] /sphereAssetA_C: trying to clone a NULL object 
00:11:04  2427MB WARNING |     [ginstance] /sphereAssetA_A: trying to clone a NULL object 
00:11:04  2427MB WARNING |     [ginstance] /sphereAssetA_B: trying to clone a NULL object 00:11:04  2428MB         |     creating root object list ... 
00:11:04  2428MB         |    node initialization done in 0:00.04 (multithreaded)






// Stephen Blair
// Arnold Renderer Support
Message 4 of 4

Thanks for reporting it !

It was indeed a regression caused by other improvements with instanceable primitives. If such primitives don't have any prototype, they should be treated as regular primitives.

Fix in flight in https://github.com/Autodesk/arnold-usd/pull/1050

Thanks


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report