Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

issue with aiRoundCorners, bump and normalmaps through glass/refraction/transmission -like materials

4 REPLIES 4
Reply
Message 1 of 5
richard
470 Views, 4 Replies

issue with aiRoundCorners, bump and normalmaps through glass/refraction/transmission -like materials

Hello!

I do not know if it is a bug or an issue, but I have a problem with some attributes not working as expected through glasslike materials.
I am running Arnold 6 with maya 2020, cpu rendering. I am trying to render 'aiRoundCorners' through refractive/transmissive material but the aiRoundCorners won't show through.

There are some issues with bump and normalmaps as well through glass. Mainly on surfaces away from the camera. The transmission seems to do something weird with the normals.

aiRoundCorners_throughGlass_01.png

bumpNormal_throughGlass_01.png

Labels (4)
4 REPLIES 4
Message 2 of 5
lee_griggs
in reply to: richard

I can confirm the issue with transparent surfaces.

>There are some issues with bump and normalmaps as well through glass. Mainly on surfaces away from the camera. The transmission seems to do something weird with the normals.

Is this with round_corners or just normal maps alone? Can you share some images and/or a simple scene, please?

Are they single-sided surfaces?

6701-1586957370479.png

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 5
richard
in reply to: lee_griggs

I did include some images with the post.
But I could include a simple scene as well soon.

It is same both with aiRoundCorners alone and combined with normal and bumpmap.

I tried with a cube and a single sided mesh/poly. I also tried to turn on and off on the 'Opaque' in the shape of the glass object as well. But there was no difference.

Message 4 of 5
richard
in reply to: richard

Here is a basic scene. But only with aiRoundCorners setup.

https://drive.google.com/drive/folders/1wtK0hKRRjKlv-b4FQ_n4WOSRUqRRzZNl?usp=sharing

Message 5 of 5
joie
in reply to: richard

Is this something to be fixed soon?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report