Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Installing .dll files not working

4 REPLIES 4
Reply
Message 1 of 5
blastframe
412 Views, 4 Replies

Installing .dll files not working

Hello,

I am trying to install some .dll shaders for Arnold in Maya, but it doesn't seem to be working.

I have added the files to these locations and added those to the Maya.env file:

ARNOLD_PLUGIN_PATH=C:\Users\kevin\Documents\maya\shaders
MTOA_TEMPLATES_PATH=C:\Users\kevin\Documents\maya\ae

arnold-dll.png


There are .osl shaders in this ARNOLD_PLUGIN_PATH folder that are working, but not the .dll. How do I get the .dlls to work in Arnold?

Maya version: 2022.1
MtoA: 4.2.3
Arnold Core: 6.2.1.1
OS: Windows 10 Pro 20H2


Thank you.

Labels (4)
4 REPLIES 4
Message 2 of 5
Stephen.Blair
in reply to: blastframe

Those alShaders are too old. They are incompatible with Arnold 6



// Stephen Blair
// Arnold Renderer Support
Message 3 of 5
blastframe
in reply to: Stephen.Blair

Thank you for the quick reply, Stephen. I was using those as a test to see if I could load any dlls. I've removed them, but I've also got some .dlls that were made for Arnold 6.2. Those are the ones I'm really trying to get working. Those should work with 6.2.1.1, right?

screenshot-2021-07-30-123840.png


Message 4 of 5
Stephen.Blair
in reply to: blastframe

@

Check an Info-verbosity-level log for a render to see what's happening.



// Stephen Blair
// Arnold Renderer Support
Message 5 of 5
maxtarpini
in reply to: blastframe

Most likely your dlls are missing some other dlls (compiler stuff generally) .. use a dll inspector to check that. Dependency Walker for example.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report