Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bifrost not rendering custom location

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
tinoxps
416 Views, 12 Replies

Bifrost not rendering custom location

Hello,

 

I am having trouble. My foam is not rendering on launch of command line rendering.
I have a custom location for arnold and I use

set MAYA_MODULE_PATH=G:\arnoldversions\5111\2022;%MAYA_MODULE_PATH%
set MAYA_RENDER_DESC_PATH=G:\arnoldversions\5111\2022;%MAYA_RENDER_DESC_PATH%
 
to start it. The mtoa.mod on that location points also correctly everywhere:
+ mtoa any G:\arnoldversions\5111\2022
PATH +:= bin
MAYA_CUSTOM_TEMPLATE_PATH +:= scripts/mtoa/ui/templates
MAYA_SCRIPT_PATH +:= scripts/mtoa/mel
MAYA_RENDER_DESC_PATH += G:\arnoldversions\5111\2022
MAYA_PXR_PLUGINPATH_NAME += G:\arnoldversions\5111\2022\usd
 
I also set just in case the following env variable:
set BIFROST_ARNOLD_PATH=%BIFROST_ARNOLD_PATH%;G:\arnoldversions\5111\2022\extensions\bifrost\1.5.0
 
still I am getting the following error on the command prompt:

00:00:03 795MB ERROR | [mtoa] [bifrostTranslator] Could not find arnold_bifrost in search path C:/Program Files/Autodesk/Bifrost/Maya2022/2.2.1.0/bifrost/

00:04:04 11809MB ERROR | [mtoa.translator] bifrostTranslator: Arnold node type bifrost_polymesh does not exist.

00:04:04 11809MB ERROR | [mtoa.translator] bifrostTranslator: Arnold node type bifrost_points does not exist.

 

If I nagivate to the location, I indeed find some files

 
tinoxps_0-1651576019596.png

 

12 REPLIES 12
Message 2 of 13
Stephen.Blair
in reply to: tinoxps

The location of MtoA doesn't matter. 

What's in the Bifrost module file? That's what MtoA uses to find Bifrost.

MtoA is looking in 

C:/Program Files/Autodesk/Bifrost/Maya2022/2.2.1.0/bifrost/

 

Not 

C:/Programme



// Stephen Blair
// Arnold Renderer Support
Message 3 of 13
tinoxps
in reply to: Stephen.Blair

Hi Stephen,

 

Program Files = Programme for german PCs.

the bifrost mod look like so:

+ PLATFORM:win64 LOCALE:en_US Bifrost 2.2.1.0 bifrost
BIFROST_LOCATION:=
PATH+:=bin
[r] scripts: scripts
MAYA_CONTENT_PATH+:=examples/Bifrost_Fluids
MAYA_MODULE_UI_WORKSPACE_PATH+:=resources/workspaces
MAYA_TOOLCLIPS_PATH+:=resources/toolclips
BIFROST_LIB_CONFIG_FILES+:=resources/plugin_config.json
PYTHONPATH+:=python/site-packages

 

it has two more plattforms for chinese and japanese languages.

Message 4 of 13
Stephen.Blair
in reply to: tinoxps

Progamme is not the actual folder name on disk?


Also, the bifrost module file is missing the actual Bifrost location.

+ PLATFORM:win64 LOCALE:en_US Bifrost 2.4.0.0 C:\Program Files\Autodesk\Bifrost\Maya2023\2.4.0.0\bifrost
BIFROST_LOCATION:=
PATH+:=bin
[r] scripts: scripts
MAYA_CONTENT_PATH+:=examples/Bifrost_Fluids
MAYA_MODULE_UI_WORKSPACE_PATH+:=resources/workspaces
MAYA_TOOLCLIPS_PATH+:=resources/toolclips
BIFROST_LIB_CONFIG_FILES*:=resources/plugin_config.json
PYTHONPATH+:=python/site-packages

+ PLATFORM:win64 LOCALE:zh_CN Bifrost 2.4.0.0 C:\Program Files\Autodesk\Bifrost\Maya2023\2.4.0.0\bifrost
BIFROST_LOCATION:=
MAYA_PLUG_IN_RESOURCE_PATH+:=resources/l10n/zh_CN
PATH+:=bin
[r] scripts: scripts
MAYA_CONTENT_PATH+:=examples/Bifrost_Fluids
MAYA_MODULE_UI_WORKSPACE_PATH+:=resources/workspaces
MAYA_TOOLCLIPS_PATH+:=resources/l10n/zh_CN
BIFROST_LIB_CONFIG_FILES*:=resources/plugin_config.json
PYTHONPATH+:=python/site-packages

+ PLATFORM:win64 LOCALE:ja_JP Bifrost 2.4.0.0 C:\Program Files\Autodesk\Bifrost\Maya2023\2.4.0.0\bifrost
BIFROST_LOCATION:=
MAYA_PLUG_IN_RESOURCE_PATH+:=resources/l10n/ja_JP
PATH+:=bin
[r] scripts: scripts
MAYA_CONTENT_PATH+:=examples/Bifrost_Fluids
MAYA_MODULE_UI_WORKSPACE_PATH+:=resources/workspaces
MAYA_TOOLCLIPS_PATH+:=resources/l10n/ja_JP
BIFROST_LIB_CONFIG_FILES*:=resources/plugin_config.json
PYTHONPATH+:=python/site-packages

 



// Stephen Blair
// Arnold Renderer Support
Message 5 of 13
tinoxps
in reply to: tinoxps

I think I found something.
The warning says
[mtoa] [bifrostTranslator] Could not find arnold_bifrost in search path C:/Program Files/Autodesk/Bifrost/Maya2022/2.2.1.0/bifrost/
but the arnold_bifrost file is actually in one of these three folders:
C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost\arnold-6.2.0.0
C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost\arnold-6.0.0.0
C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost\arnold-5.3.0.0

probably they arrive there when I made an automatic installation
since I am using custom installs now, and the arnold version is 7.1.1.1.... can I just set any of the previous folders, if so then which is the env variable? if not, where do I get the files for arnold_bifrost.dll version 7.1.1.1 of arnold?

Message 6 of 13
tinoxps
in reply to: Stephen.Blair

I tried this, just in case, but did not worked

set BIFROST_LOCATION=C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost
 
same error
Message 7 of 13
Stephen.Blair
in reply to: tinoxps

That old Bifrost won't work with the latest MtoA.

 

In a command prompt, run this command?

dir "C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost"


// Stephen Blair
// Arnold Renderer Support
Message 8 of 13
tinoxps
in reply to: Stephen.Blair

I get this:

Volume in Laufwerk C: hat keine Bezeichnung.
Volumeseriennummer: 020E-CADD

Verzeichnis von C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost

29.03.2021 15:03 <DIR> .
29.03.2021 15:03 <DIR> ..
29.03.2021 15:03 <DIR> arnold-5.3.0.0
29.03.2021 15:03 <DIR> arnold-6.0.0.0
29.03.2021 15:03 <DIR> arnold-6.2.0.0
29.03.2021 15:03 <DIR> bin
29.03.2021 15:03 <DIR> examples
29.03.2021 15:03 <DIR> icons
29.03.2021 15:03 <DIR> plug-ins
29.03.2021 15:03 <DIR> python
29.03.2021 15:03 <DIR> resources
29.03.2021 15:03 <DIR> scripts
29.03.2021 15:03 <DIR> sdk
29.03.2021 15:03 <DIR> thirdparty
0 Datei(en), 0 Bytes
14 Verzeichnis(se), 18.565.586.944 Bytes frei

 

I just tried running the installer again automatically and installing everything in the standard and this dir stays actually the same. In the Autodesk\Bifrost folder, comes nothing new.

 

I found however under another location the following:
C:\Program Files\Autodesk\Bifrost\Maya2022\2.3.1.0\bifrost\arnold-7.0.0.0

I think this is from an update of maya 2022... maybe I could take the files from these folders and move them into the goal location? Or can I place them somewhere and use an env variable?

Message 9 of 13
Stephen.Blair
in reply to: tinoxps

I would get the latest Bifrost.

MtoA 5.1.1 requires at least Bifrost 2.3.1.0

 

https://newpossible.autodesk.com/bifrost



// Stephen Blair
// Arnold Renderer Support
Message 10 of 13
tinoxps
in reply to: Stephen.Blair

Thanks I will give it a try and let you know, but

 

do I need to worry about the arnold subfolder versions?
or 

Is there a way I could direct to
C:\Program Files\Autodesk\Bifrost\Maya2022\2.3.1.0\bifrost
and not to
C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost

 

if both are in the same machine?

 

 

Message 11 of 13
Stephen.Blair
in reply to: tinoxps


@tinoxps wrote:

Thanks I will give it a try and let you know, but

 

do I need to worry about the arnold subfolder versions?
or 

Is there a way I could direct to
C:\Program Files\Autodesk\Bifrost\Maya2022\2.3.1.0\bifrost
and not to
C:\Program Files\Autodesk\Bifrost\Maya2022\2.2.1.0\bifrost

 

if both are in the same machine?

 

 


The Bifrost installer will update the bifrost.mod module file

And MtoA will use that to find Bifrost

And load the 7.1 version of the Arnold bifrost nodes



// Stephen Blair
// Arnold Renderer Support
Message 12 of 13
tinoxps
in reply to: Stephen.Blair

In the end, I upgraded also Maya on the other PCs. But still, the foam was missing since that Bifrost version does not run with MtoA 5.1.1.1 ... so I downgraded the MtoA to 5.0.0 to match what that Bifrost version can. Seems to work, since the rendering is now taking longer, but at some point, I get this error 
Arnold renderer signal caught: error C0000005 -- access violation

So, I think I will need to check something in the scene, to see what's going on there. Thanks for the help, it also allows me to understand much better the situation.

Message 13 of 13
sanjayk02LPSPQ
in reply to: tinoxps

Thank this help me a lot

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report