Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold Denoise Noice crashing on initial render

11 REPLIES 11
Reply
Message 1 of 12
Anonymous
994 Views, 11 Replies

Arnold Denoise Noice crashing on initial render

 
Tags (2)
Labels (2)
11 REPLIES 11
Message 2 of 12
lee_griggs
in reply to: Anonymous

What does the log file say?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 12
Anonymous
in reply to: Anonymous

Hi Lee, tx replying. Attached is log file. I set it to output debug.log-win.txt

Also attached is the previous render log- a successful one.logsuccess-win.txt

On a mac it crashes at the same point, but says illegal memory something ( sorry not at that computer )

I have also tried optimising the file before rendering.

Message 4 of 12
Stephen.Blair
in reply to: Anonymous

What is crashing? The render, or noice?

noice is a separate process that you run on the files that were rendered.

Or do you mean that the crash happens only when you enable Output Denoising AOVs?



// Stephen Blair
// Arnold Renderer Support
Message 5 of 12
Anonymous
in reply to: Anonymous

Hi @Stephen Blair Noice - the seperate after you render is working. BUT I can t render a sequence to begin with - well more than a few frames. So its the initial MtoA render with the enabled denoise box ticked. Another odd thing is - the render viewport window that shows the progress of the render seems to show different AOV's - or at least some of them, in a cycle - render 1 is Beauty, Render 2 shows the Z Aov, Reneder 3 shows the Normal AOV , Render 4 shows Beauty, Render 5 shows Z Aov , and sometimes it shows the Variance AOV and so it goes ..... till it crashes 🙂

Normally - ie with no denoise output aov the render window just shows the beauty AOV.

Just found a mac log file

initializing 407 nodes ... 00:00:06 4229MB ERROR | signal caught: SIGABRT -- Abnormal process @Lee Griggs

if that helps.

Message 6 of 12
Stephen.Blair
in reply to: Anonymous

Ok, so the crash has nothing to do with denoising.

The shifting AOVs is a known issue, but it doesn't cause a crash.

Impossible to tell why it crashes. Can you post a simplified scene that reproduces the crash?



// Stephen Blair
// Arnold Renderer Support
Message 7 of 12
Anonymous
in reply to: Anonymous

Hi @Stephen Blair, link to file, and last 2 logs of test. The render sequence went for 45 min (the last log is crashed)

https://www.dropbox.com/s/2zjnzn9z4d9ia8t/Test_Arnold.zip?dl=0

If Arnold / Autodesk etc has a file that they know doesnt crash I m happy to test that if someone can send.

Message 8 of 12
Anonymous
in reply to: Anonymous

Hi @Stephen Blair, I have tested another scene on a windows mechine and received a error initializing 196 nodes ... 00:00:10 4788MB ERROR | signal caught: error C0000005 -- access violation.. I searched this and see there are other posts with this error - although you have said its a vague error. they all seem to be unresolved.

Message 9 of 12
Anonymous
in reply to: Anonymous

Just checking for a response @Stephen Blair - is there actually an official support system?

Message 10 of 12
Stephen.Blair
in reply to: Anonymous

Do you have Arnold subscription and support?



// Stephen Blair
// Arnold Renderer Support
Message 11 of 12
Stephen.Blair
in reply to: Anonymous

signal caught: error C0000005 -- access violation

Could be anything.

Try to isolate the problem. One approach is to enable all the Ignore options (Render Settings > Diagnostics). If you don't crash, then re-enable one by one until you do crash.

Another approach: start removing things from the scene until the crash stops. Then you have an idea of where the problem is.



// Stephen Blair
// Arnold Renderer Support
Message 12 of 12
Anonymous
in reply to: Anonymous

Hi Ju Wo: I'm with the same problem here, and losing my mind to solve it. Did you find a solution for this? I don't find more information than your comments. Thank you!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report