Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

aiImage autoTx default to 0

2 REPLIES 2
Reply
Message 1 of 3
Anonymous
268 Views, 2 Replies

aiImage autoTx default to 0

Hi,

i'm struggling to find a way for setting autoTx attribute in aiImage node to False by default.

My approach has been to edit the mtoa.mtd file and try to give a value for that, but I found no success. This is what I tried:

[attr auto_tx]

default BOOL false


I also tried [attr autoTx], setting the type to INT 0, maya.autoTx BOOL 0... I don't know how many options I have already tried, but couldn't make it work.


Do you know how this would be possible?

Thanks!

Tags (1)
Labels (1)
2 REPLIES 2
Message 2 of 3
Stephen.Blair
in reply to: Anonymous

You can turn off autotx in the Render Settings with a UserSetup.py in your Maya scripts folder.


import mtoa.hooks
def setupOptions(options):
    cmds.setAttr('{}.autotx'.format(options), 0);
mtoa.hooks.setupOptions = setupOptions


// Stephen Blair
// Arnold Renderer Support
Message 3 of 3
Anonymous
in reply to: Stephen.Blair

Hi Stephen,

thanks for the info. In fact I already did that previously, but didn't know it would override each File or aiImage nodes behaviour... and it does 🙂


Thanks again

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report