Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Strange error adding simple geometry to scene

Message 1 of 5
231 Views, 4 Replies

Strange error adding simple geometry to scene

If I open up a new project and just try to add a sphere (for example) to the scene, I get this error:



Traceback (most recent call last):
  File "C:/Program Files/Arnold/htoa-", line 3, in <module>['node'])
  File "C:\Program Files/Arnold/htoa-\htoa\", line 167, in initArnoldProperties
  File "C:\Program Files/Arnold/htoa-\htoa\", line 111, in addArnoldProperties
AttributeError: 'NoneType' object has no attribute 'setExpression'



In addition, all the properties have disappeared from the ROP:




Any ideas what's going on here?

Message 2 of 5

This kind of thing is almost always an environment problem.

So, check

  • houdini.env, or if you use packages, the json file
  • Help > About Houdini > Show Details

Remove other stuff and make sure HtoA works. Then add back the other stuff.

// Stephen Blair
// Arnold Renderer Support
Message 3 of 5

With an empty environment file, everything works fine. But with just these lines in the .env it's all broken:



PATH = "$PATH;C:/Program Files/Arnold/htoa-"
HOUDINI_PATH = "$HOUDINI_PATH;C:/Program Files/Arnold/htoa-;&"


The strangest thing is that everything was working fine until a few hours ago. Now I am suddenly getting this error too: Houdini Console errors 


The only thing I've done which might have caused an issue I suppose is that I ran the Redshift installer. Though I am not currently using Redshift, I don't know if it's somehow done something to some files somewhere.


Maybe a full reinstall might be in order?!

Message 4 of 5

HTOA should be at the start of HOUDINI_PATH

Also, I don't know what's in $HOUDINI_PATH. Is & being used twice when HOUDINI_PATH is expanded? That can cause problems too.

// Stephen Blair
// Arnold Renderer Support
Message 5 of 5

Ah OK, yeah I did have some lines for adding Redshift to the env but I removed them, but had left the $HOUDINI_PATH variable like that. Removing that seems to have fixed it, thanks!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report