Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Standard_surface Randomwalk2 SSS in HTOA looks different between GPU and CPU

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
Anonymous
572 Views, 6 Replies

Standard_surface Randomwalk2 SSS in HTOA looks different between GPU and CPU

Rendering skin with Randomwalk2 in GPU and I'm not getting the same beautiful look that Randomwalk2 provides under CPU rendering.

It's as if Randomwalk2 shuts off and GPU falls back to diffusion.

Anything I can do to get Randomwalk2 on GPU in HTOA?

Labels (2)
6 REPLIES 6
Message 2 of 7
Slava_91
in reply to: Anonymous

Hi, Diffusion SSS is not supported on GPU. Can you attach screen with problem or wrote more information about it, what exactly happened, so you think this is diffusion?

Message 3 of 7
Anonymous
in reply to: Anonymous

Thanks for answering Slava -


I just tested in a new scene in prep for posing an A/B here for you, and GPU renders skin exactly the same as CPU now - I must have been doing something wrong in the previous scene.


All is good - this is beautiful skin shading done on the GPU.

Message 4 of 7
Anonymous
in reply to: Anonymous

Hi @slava

Actually I do still have an issue now that I've scaled the object down to 0.01 which I should have done before answering that everything was okay above. I think this is certainly regarding scene scale.


My human model (from Maya at 180cm) is scaled to 0.01 units in Houdini which would be the correct height of a human (1.8 meters).


Subsurface scale is set to 0.001 which looks somewhat "correct" using CPU based Randomwalk2.


Here is what that looks like in this quick test:7273-cpu.png


Here is the same asset rendered using GPU as a render device:

7277-1591571512550.png

I'm scaling the asset using a transform sop under a file node and converting it to polygons.7278-1591571798954.png


Message 5 of 7
Anonymous
in reply to: Anonymous

Also here are the GPU / CPU logs if it helps you.


arnold_log_GPU.txt

arnold_log_CPU.txt

Message 6 of 7
Anonymous
in reply to: Anonymous

@leegriggs


I jumped the gun and accepted Slava's answer before scaling the model properly and reopening the issue, so didn't get a fix for this yet.


Please see the images and comments below ( I attached logs if it helps to decipher the possible scene scale issue)

Message 7 of 7
403504414
in reply to: Anonymous

It could be an issue with the render settings not being set correctly. It is correct to set the system export scale to 1cm in the rendering settings.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report