Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Solaris: Massive slowdown in HdEngine:Execute

4 REPLIES 4
Reply
Message 1 of 5
kevin.vandenoever89YWD
288 Views, 4 Replies

Solaris: Massive slowdown in HdEngine:Execute

Hi, We are evaluating more recent versions of HtoA for use at our Studio and have run into an alarming slowdown (orders of magnitude) in time to first pixel of IPR and husk rendering. 

our current production version of arnold is HtoA 6.2.1.1, and we are testing the latest HtoA 6.2.4.3.

 

To eliminate any potential issues with our data, we've tested USDAlab 2.0.1 and can replicate the issue:

  •  The time to first pixel goes from ~6 seconds in HtoA 6.2.1.1 to ~480 seconds in HtoA 6.2.4.3.
  • tested separately on both linux and windows, and this happens both in husk rendering as well as viewport IPR.
  • We could get away with using sick instead of husk, but for viewport rendering this is hugely problematic.

At a glance it seems something is up with wait time during material translation.

Attached are chrome://tracing files for the two versions, as well as some screengrabs shown below:

alab_husk_htoa6243_linux.png

alab_husk_htoa6211_linux.png

  

 

Labels (4)
4 REPLIES 4
Message 2 of 5

That looks just like something Arnold support already logged with the HtoA development team (ticket reference: HTOA-2413)

 

Why does a studio uses a peer-to-peer forum instead of support for something like this?

 

 



// Stephen Blair
// Arnold Renderer Support
Message 3 of 5

Thanks for the ticket reference, Stephen. It's sometimes hard to know which of the 5 different support services to use (forums, mailing list, support email, slack, github), but in our last call with one of Autodesk's Tech Specialists they recommended we use these forums. I suppose that was bad advice; we'll use support in future and be in touch on access to view internal tickets.

Message 4 of 5

The just-released HtoA 6.2.5.2 has a fix for this problem.

Help | HtoA 6.2.5.2 | Autodesk


Thanks

 

Stephen
Arnold Renderer Support



// Stephen Blair
// Arnold Renderer Support
Message 5 of 5

Thanks all involved.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report