Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems loading Udims in Solaris/Htoa

9 REPLIES 9
Reply
Message 1 of 10
slylebeau
1307 Views, 9 Replies

Problems loading Udims in Solaris/Htoa

Hi everyone!


We have a Character that uses Udims textures and we are facing this problem in Solaris.

When rendering directly in the hydra viewport everything appears fine.

But when trying to use a Usd_Render_rop in the OUT context, that points to the Arnold render setting node as the Lop path, we first get these errors on all textures:


00:00:00 662MB ERROR | [texturesys] could not read resolved image filename = "../../../../../disk/x/x/x/x/x/publish/textures/v002/mapName.1013.tif"

We do use the <udim> token.

While debugging, one of us tought about forcing the path to the texture using a user data string. After doing so, the error changed to this:


00:00:00 667MB ERROR | [texturesys] /assetname/materials/render/ai_lionBody/lion/materials/render/ai_lionBody/image7: Cannot retrieve ImageSpec of a UDIM-like virtual file (filename = "/disk/x/x/x/x/x/publish/textures/v002/mapName.<UDIM>.tif")


Permission of files on disk seemed okay also.

Does anyone got any clues of what we are doing wrong or if it's a bug somewhere?


houdini 18.0.532 / HtoA 5.4.0 / Arnold 6.0.4.0


Thanks in advance


sly










Tags (2)
Labels (2)
9 REPLIES 9
Message 2 of 10
pal.mezei
in reply to: slylebeau

Hi @Sylvain Lebeau


This is a known issue and we are looking into it. AFAIK it's related to using a relative vs absolute path for udims, and absolute paths should work.


Cheers,

Pal.

Message 3 of 10
slylebeau
in reply to: pal.mezei

Hi Pal! Thanks for the feedback!

As far as I know we are indeed using absolute paths.

/disk/projects/projectName/.../textureName.<udim>.tif

unsure what is going wrong.


sly

Message 4 of 10

Hi @Pal Mezei !


Both of relative and absolute path are doing the same pattern. I also tried to save in a different folder (to change the amount of ../../) but there is always the same error.


Cheers,


Aurélien

Message 5 of 10

Hi folks. Any news on this? Just got myself facing this issue today.

Message 6 of 10
dlekanis
in reply to: slylebeau

Same issue here, using absolute paths, but even though textures are rendering in hydra, when rendering to a file, or rendering the usd as a procedural, textures are missing. Doing crowds so usd is kinda the only option.


Would be nice to have an update of where we are at with this one @Pal Mezei

Message 7 of 10
pal.mezei
in reply to: dlekanis

Hi Dimitris!


As far as we know, this was fixed in one of the Houdini 18.5 releases a while ago when SideFx backported a fix from a newer USD version to their USD 20.8 build. There are some limitations like you can't mix Arnold tokens and the <udim> token.

Please try using <UDIM> instead of <udim>, and let me know how it goes.

Message 8 of 10
dlekanis
in reply to: pal.mezei

Thanx for the reply, will give newer build a go and I will let you know how it goes.

Dimitris

Message 9 of 10
sami.tawil
in reply to: slylebeau

it seems the problem is back

H403 htoa 403 as well, hydra renders properly but then render object is red

Message 10 of 10
sami.tawil
in reply to: sami.tawil

ok so if you sue .<udim>. it works in hydra but not at render time

if you use .<UDIM>. then it works for both

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report