Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ocio rules ignored with filename as user data

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
Anonymous
278 Views, 3 Replies

ocio rules ignored with filename as user data

strings.hiplc.zipHi,

I'm reading the filename from a 'User Data String' node and then connecting that to the image's texture filename string. It works fine, but the rules set in the Color Space drop down menu are ignored (and the ROP's Color Management tab as well ).


in the following render, the grid on the right is using the same image as the grid to the left, but setting filename using primitive variable (color space rules are the same on both materials).

htoa-string.png

Any idea on how to force it?

Houdini 18.5.408 / HtoA 5.5.0.1 / linux

Thanks!

Tags (2)
Labels (2)
3 REPLIES 3
Message 2 of 4
Stephen.Blair
in reply to: Anonymous

color space conversion is applied when the tx is generated, which happens before the render



// Stephen Blair
// Arnold Renderer Support
Message 3 of 4
Anonymous
in reply to: Anonymous

In that case, what could be causing the problem in the rendered planes? I'm using a different method to set up a filename (string).


Message 4 of 4
Anonymous
in reply to: Anonymous

I was generating texture paths and reading that string in my arnold shader. I was using '/path/to/texture.jpg' but I needed to use '/path/to/texture.tx' instead.

All textures go through maketx with the proper color correction flags now and now everything is working great.

That was my human mistake.


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums