Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

object properties error when added

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
jofish002
147 Views, 2 Replies

object properties error when added

Traceback (most recent call last):
File "/Users/josephibrahim/htoa/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/scripts/obj/geo.py", line 3, in <module>
htoa.properties.initArnoldProperties(kwargs['node'])
File "/Users/josephibrahim/htoa/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/scripts/python/htoa/properties.py", line 167, in initArnoldProperties
addArnoldProperties(node)
File "/Users/josephibrahim/htoa/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/htoa-6.2.2.0_rf4b9c5b_houdini-19.5.605/scripts/python/htoa/properties.py", line 111, in addArnoldProperties
node.parm('ar_matte').setExpression('ch("vm_matte")')
AttributeError: 'NoneType' object has no attribute 'setExpression'

Labels (2)
2 REPLIES 2
Message 2 of 3
Stephen.Blair
in reply to: jofish002

This kind of thing is almost always an environment problem.

So, check

  • houdini.env, or if you use packages, the json file
  • Help > About Houdini > Show Details

Remove other stuff and make sure HtoA works. Then add back the other stuff.



// Stephen Blair
// Arnold Renderer Support
Message 3 of 3
jofish002
in reply to: Stephen.Blair

Thank you!

that definitely solved the problem. 

I am still using a .env 

 But after this I’m moving to packages. 

Cheers

Joseph



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report