Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IPR GPU Mode

3 REPLIES 3
Reply
Message 1 of 4
s.thifault
577 Views, 3 Replies

IPR GPU Mode

Changing a parameter (material) doesn't refresh the IPR in GPU mode, works fine in CPU.

Is this a Bug? or not yet implemented.. HTOA 5.0


Thanks!!

Tags (3)
Labels (3)
3 REPLIES 3
Message 2 of 4

Have you done the Pre-Populate GPU Cache in the Utility dropdown?

Without this step GPU wont work like it should. It does take around 10min to create this Cache.

It has to be done only once.


https://docs.arnoldrenderer.com/display/A5ARP/Getting+Started+With+Arnold+GPU

----------------------------------------------------------------
https://linktr.ee/cg_oglu
Message 3 of 4
s.thifault
in reply to: s.thifault

Hi,

I found the problem...this relate to both GPU and CPU rendering.

As soon as Arnold finish rendering the scene, it stops and do not refresh any more on parameter changes. Need to put higher Camera sample to keep the GPU (and CPU) running and respond to changes.

MtoA not behaving like this.. it will restart the render in the IPR as soon as something changes in the scene.


It's not related to Pre-populating the cache.


Is this normal?

BTW very impress by the progress of Arnold GPU....


Thanks

Message 4 of 4
s.thifault
in reply to: s.thifault

Also, if you have instances with displacement, and you change anything in the material, it will kill Arnold in GPU and CPU mode.

Workaround is to use pack geometry.


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report