Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HUSK command line render usd file in CPU renderfarm Error

Message 1 of 23
1024 Views, 22 Replies

HUSK command line render usd file in CPU renderfarm Error

I have a render farm and it only has CPUs, no GPU.

after I  execute husk.exe command to render a usd file. I already set use CPU to render ,and don't use any optix denoise.

I set husk verbose 9 to get very detail debug info.

Here is only what I get.


"C:\Program Files\Side Effects Software\Houdini 20.0.506\bin\husk.exe" -s /Render/rendersettings --make-output-path -f 1 -R HdArnoldRendererPlugin --purpose geometry,render --complexity high --stderr c:\husk_error.log --verbose 9 "s:/render.usda"

[11:02:47] CPU Genuine Intel(R) CPU @ 2.20GHz
[11:02:47] Architecture - AMD64: mmx xmmx sse sse2 cmov fpcmov ht sse3 ssse3 sse4.1 sse4.2 avx avx2
[11:02:47] System limit: 8192 file descriptors



then Husk crashed

after I installed a graphic card, and run the husk command again, it worked correctly.

So How to disable GPU detection when loading the Arnold Plugin?


I am using


htoa- ,


both not work.

Message 21 of 23
in reply to: amy_adams_aaa

Unfortunately that's not the dump file, but this is still useful information.


So now we know it's crashing in nvcuda64.dll (nvidia cuda library) and that this is version I would have thought you wouldn't have that library if you had all the nvidia drivers uninstalled. Can you try removing nvcuda64.dll and all the other nvidia files like nvml.dll? From the file you uploaded, I can see for nvcuda64.dll there are two copies to remove:


Just to be safe, rather than deleting them, move them to another directory where windows won't find them, so you can restore if something goes wrong. I would also do a full search of your hard drive for nvml.dll just in case you really do have it. If that doesn't work, looking online, I see a post recommending these instructions and uninstall tool, but I've never tried it myself, so can't vouch for it:


It's possible this might crash again, in which case upload the minidump if you can find it (should end in .dmp) and the new .wer file like you did previously. Maybe you need to edit the DumpFolder key in the registry to specify where you want this file to exist?

Message 22 of 23

I am sorry , I make mistakes.

Actually, I did not fully uninstall nv driver at all.

after I fully uninstall nv driver, arnold works.

and the other "clean" render farm node, is not really "clean" at all.


Message 23 of 23
in reply to: amy_adams_aaa

That's great, glad to hear this solved it. I'll report this to NVIDIA in case it's something they can fix, but hopefully this gives you a workaround.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report