Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

[HtoA] Visible to shadow rays causes issue on a shader

1 REPLY 1
SOLVED
Reply
Message 1 of 2
XtaaZ
272 Views, 1 Reply

[HtoA] Visible to shadow rays causes issue on a shader

Hi,


Houdini version: 18.0.597

HtoA version: 5.5.0.0


I have a problem with 2 geometries:

- a stone wall, textured entirely with triplanar and noises

- a book shelf, untextured (just a default Standard Surface)


Both geometries are clean, without any unnecessary attribute or group.


Here's a screenshot of the viewport:

1605227364281.png

Here's how my wall should look like in the diffuse_albedo and Ambient Occlusion AOVs -please ignore the floating pieces:

good-albedo.pnggood-ao.png


When I try to display the book shelf geometry in the render, here's what happens:

bad-albedo.pngbad-ao.png



Here's what I've tried to do or looked at so far:


- Investigated my wall shader, nothing changed

- Created a new Houdini scene, nothing changed

- Disabled the subdivision and displacement on my wall, nothing changed

- Imported new versions of the geometries, nothing changed

- Tested on both CPU and GPU, nothing changed

- Tried to display any other geometry from my scene, everything works fine until I display the book shelf geometry or the books I have on the book shelves

- A lot more stuff I don't remember (been on it for several hours now)


I checked the log file and nothing wrong or related is in it.


The only workaround I found is to uncheck the "Visible to Shadow Rays" parameter on the book shelf geometry node. With this, I can render both geometries together without having the problem.

But obviously this is not a viable solution, as I don't have the correct shadows on my book shelf geometry.


The shader that is being affected by this issue uses an AmbientOcclusion node. From what I can see after all my tests, is that the Shadow Rays of my book shelf geometry are affecting the AmbientOcclusion of my wall geometry (it basically invert the normals of my geometry but only for the AmbientOcclusion, as the N AOV looks good).


I currently run out of idea on how to fix that.


I can of course make several render layers in order to composite everything together later on, but the render is quite heavy and long on my poor PC so I'd like to avoid that as much as possible.

Tags (2)
Labels (2)
1 REPLY 1
Message 2 of 2
XtaaZ
in reply to: XtaaZ

Hi,


After a few tests I realized the ambient occlusion far clip might actually be too strong in my case (I left it at 100, which is the default).

I didn't think it would come from this, as my two geos always has the same distance between each other, but kinda make sense anyway: my geos are really really tall (250 meters), so after some point, the AO far clip needs to be reduced (or the falloff, depending on the needs).


I'm glad I found a workaround for this.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report