Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HtoA Set Parameter Operator not work for Material Assignment?

3 REPLIES 3
Reply
Message 1 of 4
Slava_91
400 Views, 3 Replies

HtoA Set Parameter Operator not work for Material Assignment?

Hi,
I use Set Parameter for material assignment but shader cant be finded and render magnetta, if use asset "assign material", material assignment fine and without troubles.
trying path shader = '../matnet1/body/OUT_material' and shader = '../matnet1/body', with relative and absolute path
can't figure out where the error is
Thanks

Labels (5)
3 REPLIES 3
Message 2 of 4
Stephen.Blair
in reply to: Slava_91

You need to use the shader name that you see in an ASS file.

That won't be ../matnet/body/OUT_material, it will be something like

/obj/matnet1/arnold_materialbuilder1/standard_surface1




// Stephen Blair
// Arnold Renderer Support
Message 3 of 4
Slava_91
in reply to: Stephen.Blair

yes, I try like this but it not work

operator1.jpg


Message 4 of 4
Stephen.Blair
in reply to: Slava_91

Please check a Debug-level Arnold log. That will show operator-related messages.

Most likely the selection expression is wrong.

For testing, try a different selection. Like one specific object, or all polymeshes



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators