Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HtoA Renderer Error

5 REPLIES 5
Reply
Message 1 of 6
Matthew_Zinn
1144 Views, 5 Replies

HtoA Renderer Error

Hey All,

I'm still relatvily new to Houdini and HtoA, but I love it so far 😉

I'm trying to render a scene where I use vellum to create pages turning in a magazine. I've separated each sheet of paper as its own group and then assigned each group its own Arnold material. When I try to preview this render in the Render View it stalls forever on "Generating Scene" and if I try to render a frame, I either get a black screen or the following error:

Error

Command Exit Code: -6

00:00:00 75MB | [hick] Received: AA: 3 3
00:00:00 76MB | [hick] Received: begin
00:00:00 76MB | [hick] Batch mode
00:00:00 76MB | log started Wed Feb 10 08:14:27 2021
00:00:00 76MB | Arnold 6.2.0.0 [5442c0b5] windows clang-10.0.1 oiio-2.2.1 osl-1.11.6 vdb-7.1.1 clm-2.0.0.235 rlm-12.4.2 optix-6.6.0 2021/01/28 00:52:57
00:00:00 76MB | running on 3Zvfx-PC, pid=14852
00:00:00 76MB | 1 x Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz (6 cores, 12 logical) with 32594MB
00:00:00 76MB | NVIDIA driver version 460.89 (Optix 60800)
00:00:00 76MB | GPU 0: GeForce RTX 3070 @ 1725MHz (compute 8.6) with 8192MB (7514MB available) (NVLink:0)
00:00:00 76MB | GPU 1: GeForce GTX 1070 Ti @ 1683MHz (compute 6.1) with 8192MB (6945MB available) (NVLink:0)
00:00:00 76MB | Windows 8 (version 6.2, build 9200)
00:00:00 76MB | soft limit for open files raised from 512 to 2048
00:00:00 76MB |
00:00:00 76MB | [hick] Start
00:00:00 76MB | [hick] Received: log_verbosity: 7942
00:00:00 76MB | [hick] Received: log_console_enable: 1
00:00:04 224MB ERROR | [polymesh] /obj/rndr_Mag/polygons: out-of-range shader index (2/2)
00:00:04 224MB ERROR | [polymesh] /obj/rndr_Mag/polygons: out-of-range shader index (2/2)
00:00:04 224MB ERROR | [polymesh] /obj/rndr_Mag/polygons: out-of-range shader index (2/2)
00:00:04 224MB ERROR | [polymesh] /obj/rndr_Mag/polygons: out-of-range shader index (2/2)
00:00:04 224MB ERROR | [polymesh] /obj/rndr_Mag/polygons: out-of-range shader index (2/2)
00:00:04 224MB WARNING | Aborted by user: received abort signal


I've tried this on GPU and CPU rendering, the same process (with assigning materials, etc) works fine with mantra.


Would really appreciate any help from the community on this.

Thanks so much

Tags (1)
Labels (1)
5 REPLIES 5
Message 2 of 6

It's /obj/rndr_May

/obj/rndr_Mag/polygons: out-of-range shader index (2/2)

Everything in there is exported as one mesh, and shaders assigned to different sets of polygons. But somehow the map from polygon to shader has bad values.



// Stephen Blair
// Arnold Renderer Support
Message 3 of 6
Matthew_Zinn
in reply to: Matthew_Zinn

thats really strange. Even stranger... I got it to work correctly using HtoA in Solaris just now. Thanks so much for your help

Message 4 of 6

Would you be able to send us your scene so we can take a look at the error please?

Message 5 of 6
Matthew_Zinn
in reply to: Matthew_Zinn

Message 6 of 6

Im having the same error no idea how to even start troubleshooting this.

I have the same error in houdini and in maya using an .ass file.

Annyone that might b able to help me out?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report