Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

HtoA inconsistent render times

3 REPLIES 3
Reply
Message 1 of 4
Erik_Lundborg
267 Views, 3 Replies

HtoA inconsistent render times

I'm rendering with HtoA on deadline right now and am having problems with the same rendernodes having different rendertimes. Rendertime right now seems to differ from about 5-10 minutes on a frame to 2-2,5 hours. The frames look completely similar and the only reason i've found seems to be a something called InitializeNodes in the deadline log. Does anyone know what Arnolds InitializeNodes does and where or how i can fix it?

Logs here

https://we.tl/t-dXLJwTAI5U

Labels (3)
3 REPLIES 3
Message 2 of 4
thiago.ize
in reply to: Erik_Lundborg

It's possible this has been fixed in a newer version of Arnold. For instance, Arnold 5.3.1.1 has the following fix:

"Node initialization does not scale when there are procedurals that create many nodes".
I would suggest upgrading to at least this version and if it's still slow, try the very latest.
Message 3 of 4

Thank you for replying! I will try to get an update but could be hard in the middle of a project. It just seems so strange that the same rendernode will differ 2 hours in rendertime between 2 frames that have nothing added or taken away.

Message 4 of 4
thiago.ize
in reply to: Erik_Lundborg

You could also try disabling options.parallel_node_init until you upgrade to a newer arnold. That of course can make that stage slower since it's just using a single CPU core, but compared to the huge slowdown you're sometimes getting, you'll probably still be much faster.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report