Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to render DeepEXR on Solaris

11 REPLIES 11
Reply
Message 1 of 12
th-watanabeX37U8
1843 Views, 11 Replies

How to render DeepEXR on Solaris

I'm currently trying to render DeepEXR on Solaris using HtoA 6.0.1.0.

I found that the Render Var LOP and Render Product LOP have a Deep setting.

But I can only render regular EXR, not DeepEXR.

What settings do I need to render DeepEXR?

Thank you.

1636699357498.png

1636699388543.png

1636699419525.png

Labels (5)
11 REPLIES 11
Message 2 of 12

Hi!

You need to go to the render product and change the product type from "raster" to "deep". That'll make the outputted exr file deep and all AOVs deep AOVs.

Message 3 of 12

Thank you for your reply.

I immediately tried the Render Product settings and no EXR was output. EXR can be output by returning the setting to raster. Maybe something is still missing. I've attached the HIP file I used for testing and the rendering logs.

Thank you.

deepEXR_Test.hip.zip

deepEXR_Test_log.txt

Message 4 of 12
klausWDHQZ
in reply to: pal.mezei

Hello was a solution found to this? When I change the Render Product "Product Type" to deep, no image gets outputted. Do we need to change/add something else somewhere?
Message 5 of 12
Stephen.Blair
in reply to: klausWDHQZ

No, I got a deep exr with just Render Product > Product Type = deep

1640110011134.png



// Stephen Blair
// Arnold Renderer Support
Message 6 of 12
Anonymous
in reply to: th-watanabeX37U8

After setting Product Type to Deep, I get this error:

<b style='color: red;'>[14:49:20] No AOVs defined for render, not all delegates will function properly</b>

I do have rgba Render Var specified, it works in raster mode.

Anything else is required?

Message 7 of 12
Stephen.Blair
in reply to: Anonymous

Yes, but is an EXR still rendered?

I've seen that "No AOVs defined for render" but the deep EXR was still rendered to disk.



// Stephen Blair
// Arnold Renderer Support
Message 8 of 12


  • Create a Render Product and change the Product Type to deep
  • Under Render Product > Arnold > Deep, set the deep driver parameters
  • Under Render Product > Arnold > Deep Filter, set the filter used for each deep aov (there is one filter for all the aovs used in a deep driver)
  • Set up Render Vars and add them to the Render Product
  • Under Render Var > Arnold > Deep, set the aov-specific parameters

An example scene is attached.

deep_rendering.hip.zip



// Stephen Blair
// Arnold Renderer Support
Message 9 of 12
Anonymous
in reply to: th-watanabeX37U8

thank you very much!

now its clear

Message 10 of 12
Anonymous
in reply to: th-watanabeX37U8

There is one issue with filename padding when rendering more then 1 frame via husk with -n parameter.

All deep file outputs are written to the first file of the sequence.

Not sure if its husk problem or "HdArnoldRendererPlugin".

Attached hip file and husk command

husk --make-output-path -f 1 -n 10 -R "HdArnoldRendererPlugin" --purpose "geometry,render" --complexity "veryhigh" --snapshot 1000 "..../usdrender_16736_32_6/__render__.usd"deep_rendering_v2.zip

Message 11 of 12
Stephen.Blair
in reply to: Anonymous

I think you need to use <F> instead of $F

That works for the "non-deep" renders. And the deep too, but husk is crashing after the third frame, with no messages or anything (but I can see that it calls WerFault on Windows).



// Stephen Blair
// Arnold Renderer Support
Message 12 of 12
Anonymous
in reply to: Stephen.Blair

what can we do about that crash? is it Arnold issue or SESI?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report