Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Houdini crash when render with motion blur

3 REPLIES 3
Reply
Message 1 of 4
nezgro79
691 Views, 3 Replies

Houdini crash when render with motion blur

Hello ! I have a scene with motion blur enabled and after 23 frames houdini crash, if I disable motion blur he make the render.


If i try to render the frame 23 alone no problems if I restart from frame 23, later he crash, Arnold log record nothing but there is the houdini log


Crash report from bgood; Houdini Version 18.5.462 [linux-x86_64-gcc6.3]
Uptime 1092 seconds
Tue Apr 6 14:32:37 2021
Caught signal 11

Traceback from 1219361 ThreadId=0x7f4431e73cc0
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo_t*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo_t*, void*) <libHoudiniUT.so>
__funlockfile <libpthread.so.0>
void GA_PageArray<void, 3l, true, false>::getRange<UT_FixedVector<float, 3l, false> >(GA_Range const&, UT_FixedVector<float, 3l, false>*) const <libHoudiniGEO.so>
ga_NumericTuple::getRange(GA_Attribute const*, GA_Range const&, float*, int, int) const <libHoudiniGEO.so>
htoa::arnold::Node::getAttributeDataFloat(float*, GA_Range const&, char const*, int, int) <libhtoa_geo.so>
htoa::arnold::Node::gatherPointPositions(AtArray*, unsigned char) <libhtoa_geo.so>
htoa::arnold::Polymesh::gather(unsigned char) <libhtoa_geo.so>
htoa::geo::Translator::gather(unsigned char) <libhtoa_geo.so>
htoa::geo::TranslatorFactory::gather(unsigned char) <libhtoa_geo.so>
htoa::geo::Object::build() <libhtoa_geo.so>
htoa::geo::PygeoObject::generate() <_htoa_pygeo.so>
_wrap_PygeoObject_generate <_htoa_pygeo.so>
PyEval_EvalFrameEx (ceval.c:4372)
PyEval_EvalFrameEx (ceval.c:4457)
PyEval_EvalCodeEx (ceval.c:3604)
PyEval_EvalFrameEx (ceval.c:4467)
PyEval_EvalCodeEx (ceval.c:3604)
PyEval_EvalFrameEx (ceval.c:4467)
PyEval_EvalCodeEx (ceval.c:3604)
PyEval_EvalFrameEx (ceval.c:4467)
PyEval_EvalFrameEx (ceval.c:4457)
PyEval_EvalFrameEx (ceval.c:4457)
PyEval_EvalCodeEx (ceval.c:3604)
PyEval_EvalCode (ceval.c:669)
PY_CompiledCode::evaluateUsingDicts(PY_Result::Type, void*, void*, PY_Result&) const <libHoudiniUT.so>
PYrunPythonStatementsFromFile(char const*, PY_EvaluationContext*) <libHoudiniUT.so>
PYrunPythonStatementsFromFile(int, char**, PY_EvaluationContext*, bool) <libHoudiniUT.so>
ROP_SohoOp::runScript(char const*, ROP_SohoOutput*) <libHoudiniOP4.so>
ROP_SohoOp::spoolScript(char const*, ROP_SohoOutput*) <libHoudiniOP4.so>
ROP_SohoOp::callSoho(double, char const*, ROP_SohoOutputMode, ROP_SohoErrorMode, char const*, char const*, bool, ROP_SohoCompression, UT_Interrupt*) <libHoudiniOP4.so>
ROP_SohoOp::renderFrame(double, UT_Interrupt*) <libHoudiniOP4.so>
ROP_Node::nextExecute(int&) <libHoudiniOP4.so>
ROP_Node::execute(double, ROP_Verbose*) <libHoudiniOP4.so>
ROP_RenderItem::render(ROP_Verbose*, int, int) const <libHoudiniOP4.so>
ROP_RenderManager::renderOrder(ROP_RenderList const&, ROP_Verbose*) <libHoudiniOP4.so>
ROP_RenderManager::render(ROP_Node*, double, double, double, bool, bool, bool, bool, bool, ROP_Verbose*) <libHoudiniOP4.so>
ROP_Node::renderCommand(ROP_RenderCmdParms&) <libHoudiniOP4.so>
ROP_Node::doRenderCommand(CMD_Args&, OP_Node*, bool) <libHoudiniOP4.so>
ROP_Node::cmdRender(CMD_Args&) <libHoudiniOP4.so>
CMD_Manager::runCommand(char*) <libHoudiniPRM.so>
CMD_Manager::internalExecute(char const*) <libHoudiniPRM.so>
CMD_Manager::processInput(CMD_Source*, char const*) <libHoudiniPRM.so>
CMD_Manager::internalSendInput(char const*, bool) <libHoudiniPRM.so>
CMD_Manager::sendInputNoLock(char const*, bool) <libHoudiniPRM.so>
CMD_Manager::executeNoLock(char const*, bool, std::ostream*, std::ostream*, bool, bool) <libHoudiniPRM.so>
void UT_TaskArena::callbackConst<CMD_Manager::execute(char const*, bool, std::ostream*, std::ostream*, bool, bool)::{lambda()#1}>(void const*) <libHoudiniPRM.so>
tbb::interface7::internal::task_arena_base::internal_execute(tbb::interface7::internal::delegate_base&) const (arena.cpp:1035)
TBBPROXY_TaskArenaExecute <libTBBPROXY.so>
CMD_Manager::execute(char const*, bool, std::ostream*, std::ostream*, bool, bool) <libHoudiniPRM.so>
OPUI_RenderDialog::launch(ROP_Node*, ROP_RenderMode) <libHoudiniAPPS2.so>
ROP_Node::doRenderCback(void*, int, double, PRM_Template const*) <libHoudiniOP4.so>
OP_Node::triggerParmCallback(PRM_Parm*, double, int, void*, UT_Options const*) <libHoudiniPRM.so>
PSI2_DialogPRM::performParmCallback(PRM_Parm*, int) <libHoudiniAPPS2.so>
OPUI_DialogPRM2::performParmCallback(PRM_Parm*, int) <libHoudiniAPPS2.so>
PSI2_Dialog::triggerParmCallback(OP_Node*&, PRM_Parm*&, int, bool&) <libHoudiniAPPS2.so>
PSI2_Dialog::parmChanged(int, UI_Reason, int, bool) <libHoudiniAPPS2.so>
PSI2_Vector::changed(UI_Object*, UI_Reason, UI_DeviceEvent*) <libHoudiniAPPS2.so>
UI_Button::endSelect(UI_Event*) <libHoudiniUI.so>
SI_ParmButton::endSelect(UI_Event*) <libHoudiniUI.so>
UI_Window::handleEvent(UI_Event*) <libHoudiniUI.so>
UI_Queue::processNextEvent() <libHoudiniUI.so>
UI_Queue::drain() <libHoudiniUI.so>
UI_Queue::eventLoop() <libHoudiniUI.so>
main <libHoudiniUI.so>
__libc_start_main (libc-start.c:308)
main <hindie-bin>

Labels (3)
3 REPLIES 3
Message 2 of 4
mzappettini
in reply to: nezgro79

Did you find a solution yet? I have the same crash with the same configuration as yours. Houdini 18.5 on Linux. Same crash code. In my case I don’t know if motion blur is related. It rendered okay, then it started crashing on one of the first few frames in the sequence randomly.

Message 3 of 4
nezgro79
in reply to: nezgro79

hi

i think autodesk know this problem but they don't have a solution at this time

i've tried on grid market and is the same problem on 5 computers with motion blur, i'm done with arnold i don't renew my license and go to redshift


there is an answer from grid markets support

"Judging from what I'm seeing, this is actually a reasonably common error with Arnold and I'm not finding a cause or a solution. Here is a link to a post on Autodesk about a very similar occurrance.
https://answers.arnoldrenderer.com/questions/1573/arnold-is-constantly-crashing.html "


Years ago i'm used arnold with C4d before autodesk i dont have any problem now i've always have a problem with Arnold , withblur, licencing, generate tx file when he want or other radom bug.

Arnold is a great render engine but, to have a good help or support it's really hard when you're an indie i can't wait too much for an answer and i need to work and render my project


most of the people here are helped and thak you to all me but Arnold for houdini have a lot of problems and arnold answer is not the best way to be helped

after 3 month of work on this project and cant find a solution for arnold i do my blur in nuke and next project will be another render engine maybe redshift or renderman and renderman is free...

Message 4 of 4
julian.hodgson
in reply to: nezgro79

Sorry to hear you're having issues with the motion blur.


Do you have a simple scene we can run to reproduce the problem?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums