Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Hair not rendering the second i turn MB on !

4 REPLIES 4
Reply
Message 1 of 5
rmeyaZG7PS
173 Views, 4 Replies

Hair not rendering the second i turn MB on !

Hi there ! I'm in a bit of a pickle right now ! 

I'm trying to render a deer full of FUR using Houdini - Arnold and the second i turn on the motion blur it crashes right aways.
Locally and on the farm giving this error message : Error: OutOfMemoryException : Exception of type 'System.OutOfMemoryException' was thrown.

The hairs are generated from Houdini I tried to render it with a grey shader, low resolution, low samples, extending the cache size, enable the "expand procedural" option in the rop.
I even tried on a sphere that i animated on few frames : still crashes right away.
In mantra it's working without any issue but the goal is to have it in Arnold obviously.

Any idea, thoughts about what i'm missing ? i'm short of options and dont really know what to look for.

4 REPLIES 4
Message 2 of 5
thiago.ize
in reply to: rmeyaZG7PS

You're running out of memory, so you likely have too many motion keys, too many curves, and/or too many curve segments.

Message 3 of 5
rmeyaZG7PS
in reply to: rmeyaZG7PS

But then to me, what's doesn't make sense is why it's rendering fine in Mantra ? Should it run out of memory too ? the only difference is the shader.
I'm gonna check it out thought. Thanks ! I will definitely give an update tomorrow 🙂 

Message 4 of 5
rmeyaZG7PS
in reply to: rmeyaZG7PS

Still no success, here's what i have if that can help more : 

Deer.jpg

 Again, i have no knowledge if those values are way too much or not...
the Hair artist told me it was very minimal.

Message 5 of 5
thiago.ize
in reply to: rmeyaZG7PS

I don't know if htoa is doing this, but I know in some situations there'd be issues like the DCC (maya, houdini, etc.) applying subdivisions and then the plugin (mtoa, htoa, etc.) again applying subdivisions on top of that. Maybe there's a double count somewhere and you need to disable one of those? Unfortunately I am not familiar with htoa, so apologies I can't be more helpful.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums