Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Completely unable to use Arnold within topnets (ropfetch)

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
andrewlouda
147 Views, 4 Replies

Completely unable to use Arnold within topnets (ropfetch)

Hey, 

I've been running into a serious issue when using a ropfetch node to grab a USD Render ROP set to Arnold. Every time I try to run the ropfetch node, an Autodesk Licensing executable returns an error saying something about QT frameworks. Because of that, all of the renders are watermarked as if I don't have license, and for every single frame I want to render, I get an individual popup error message from the Autodesk Licensing executable (the first time I was away from my computer and I had to close out 120 individual error windows). I'm away from my computer so I can't get the exact error, but I can if needed.

 

My understanding is that QT is a framework for interfaces, so I tried rendering it with the scheduler set to "Requires GUI Window," but I still got the error.

 

I'm on HtoA 6.2.5.1 and Houdini 19.5.805 Py3.9

4 REPLIES 4
Message 2 of 5
BigRoy
in reply to: andrewlouda

The error you are getting is likely one of these:

 

  1. https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/This-application-f...
  2. https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/This-application-f...

 

Admittedly, since we started using Autodesk Deployment packages for installing we get this annoying popups ALL THE TIME when the batch renders kick in from our render farm. The "workarounds" mentioned there didn't work - we've updated all autodesk license manager apps as well, etc.

 

Really hoping this gets some more attention with some actual decent answers on how to really fix these.

Message 3 of 5
Stephen.Blair
in reply to: andrewlouda

I think it's more likely that the wrong Qt platforms are being loaded...and that it's an environment problem.

https://arnoldsupport.com/2022/09/20/the-case-of-the-hrender-that-failed-to-start-adsklicensingagent...



// Stephen Blair
// Arnold Renderer Support
Message 4 of 5
BigRoy
in reply to: andrewlouda

That does make way more sense - I wonder why we keep getting popup errors then on just our mayabatch deadline renders. Will try to maybe play a bit with Process Monitor if our farm machines are getting this again.

Message 5 of 5
andrewlouda
in reply to: Stephen.Blair

That seems to have fixed it! I added the variable to my Arnold.json package file so that I don't need to worry about it going forward. I suspected that it had something to do with the environment, but I didn't have much of an idea of where to go from there.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report