Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't run the installer for Houdini 18.5.408 on Windows 10

11 REPLIES 11
SOLVED
Reply
Message 1 of 12
lumogas
1198 Views, 11 Replies

Can't run the installer for Houdini 18.5.408 on Windows 10

Hello,

I'm trying to run the installer for Houdini 18.5.408 (Houdini Indie).

Whenever it reaches the 60% mark it gets stuck. Clicking on "Show Details" gives this error:

arnold-error.png

The installer window looks like this:

arnold-installer.png

I've restarted, reinstalled Houdini (and license), no luck.

I'm using Windows 10. What am I missing?

Tags (1)
Labels (1)
11 REPLIES 11
Message 2 of 12
Stephen.Blair
in reply to: lumogas

Click Ignore. You probably already have the Visual C++ 2015-2019 redistributable installed.



// Stephen Blair
// Arnold Renderer Support
Message 3 of 12
lumogas
in reply to: lumogas

Thanks for the reply!

Ok, I've clicked "Ignore", I get an "Installation Finished", but no Arnold shelf.

Any step I'm missing?

arnold-missing-shelf.png

Thanks again.

Message 4 of 12
Stephen.Blair
in reply to: lumogas

Is there anything logged in the Houdini Console at startup?



// Stephen Blair
// Arnold Renderer Support
Message 5 of 12
lumogas
in reply to: lumogas

Thanks again for the reply. I'm not getting any console messages on startup. I've tried starting it from the dos shell, and no console messages there either. If that helps.

What else can I do to check whether there is anything logged at startup?

Message 6 of 12
Stephen.Blair
in reply to: lumogas

That means HtoA is not loaded (unless you see anything Arnold-related in Houdini, like the Arnold menu or any Arnold nodes).

So, first check that you have the Microsoft Visual C++ 2015-2019 Redistributable installed (Use Settings > Apps and Features).

Then, if you have that Redistributable, it's probably an environment problem, and we need to check the houdini.env file and the details from Help > About Houdini > Show Details



// Stephen Blair
// Arnold Renderer Support
Message 7 of 12
lumogas
in reply to: lumogas

Ok, so the redistributable seems to be there... Installed today, so the installer seems to have done something, at least.

1608227000803.png

I enclose the Houdini_Info.txt resulting from Houdini->Show Details

Houdini_Info.txt

Message 8 of 12
julian.hodgson
in reply to: lumogas

Thanks for reporting - it looks like you're hitting a bug in the version of the installer we are using. We have a new version of HtoA out shortly which has an upgraded installer, and this may fix the issue - it would be good to get your feedback when this is out.

Since you have already got the vc_redist installed on your system, you should be able to run the installer with the "Extract Contents Only" to get the HtoA installation into your home directory. You might have to remove the old directory if present before doing this.

Then just make sure your houdini.env file is setup correctly i.e. see https://docs.arnoldrenderer.com/display/A5AFHUG/Installation and make sure you have the HOUDINI_PATH and PATH variables set up correctly pointing to your new installation.

Let us know how you get on.

Message 9 of 12
lumogas
in reply to: lumogas

Thanks for the extra help. I've modified the environment variables as suggested and the good news is the shelves now appear... But running anything in them gives an error. I get this if I try to create a light:

arnold-error-20201218.png

...but at least the messages on the console are more promising:

arnold-console.png

...so I will try uninstalling and reinstalling using "Extract Contents Only". What could possibly go wrong? 🙂

I will let you know if it works this time round. Thanks again.

Message 10 of 12
lumogas
in reply to: lumogas

Ok, I've tried the custom install using the "Extract Contents Only" option. It goes faster, doesn't get stuck.

Then I double checked the environment variables. All good.

Then I opened Houdini. The shelves and menus are there. However, when I try to create a light using the shelf, I get an error like the one I got this morning. I enclose it here:

arnold-error-custom-install.png

If it helps, when I try to create an "Arnold ROP" node, it creates it fine. No error. That was also the case this morning, though.

(I get error messages on pretty much everything else on the shelf).

What else can I try next?

Message 11 of 12
Stephen.Blair
in reply to: lumogas

That's all typical of a problem with the environment, so I would check houdini.env and the details from Help > About Houdini > Show Details. Look at the PATH and HOUDINI_PATH.

Compare with this:
Houdini_Info.txt



// Stephen Blair
// Arnold Renderer Support
Message 12 of 12
lumogas
in reply to: lumogas

Thanks, that seemed to do it. Turns out I had two houdini.env files, one in

...Users/me/houdini18.5

the other one in

...Users/me/Documents/houdini18.5

Houdini was checking out the first one, and I had edited the second one.

At least I can get the shelf to generate a light now. Relief!

I don't dare try a render yet, I want to end my day on this fleeting moment of success.

Thanks again for your help.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums