Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold shader nodes not showing in Houdini

13 REPLIES 13
Reply
Message 1 of 14
willibarret2000
2529 Views, 13 Replies

Arnold shader nodes not showing in Houdini

01_img.pngI'm trying to create a basic material, I can create the Arnold Shader Network but if I dive into it there is no Standard surface nor any other shader.

I guess the Env. file is set up correctly since the Arnold tab is present, so I don't understand what I'm doing wrong.


I'll attach a picture, thanks in advance for the help.

Tags (1)
Labels (1)
13 REPLIES 13
Message 2 of 14
pal.mezei
in reply to: willibarret2000

Hi!

Can you share your environment with us? Go to Help / About Houdini / Show Details, press Save and share the resulting file.

Cheers,

Pal.

Message 3 of 14

Houdini_Info.txt

the same problem

Message 4 of 14

How do you start Houdini? Start it from the Houdini Command Line Tools, don't double click on a hip file.



// Stephen Blair
// Arnold Renderer Support
Message 5 of 14

This is my problem8022-1598221686457.png

Message 6 of 14
pal.mezei
in reply to: willibarret2000

Hi!

I think I found your issue. Looking at the env file, I noticed that the HTOA folders are present twice both in PATH and HOUDINI_PATH, and doing the same thing locally broke my shaders.

You can try the following:

Locate your houdini.env file (should be in C:\Users\pablo\Documents\houdini18.0) and make sure the PATH and HOUDINI_PATH contains the HTOA folders only once.

It should look like if you are using the HtoA installer:


# htoa config start

PATH = "$PATH;C:/Users/pablo/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-${HOUDINI_VERSION}/scripts/bin"

HOUDINI_PATH = "C:/Users/pablo/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-${HOUDINI_VERSION};&"

# htoa config end

After this, go to control panel / system / advanced system settings / environment variables and make sure PATH or HOUDINI_PATH does not contain any htoa specific folders there. (and logout/login if you do remove something from there)

After all this, reopen Houdini and the shader nodes should be visible again.

Please let me know if this works for you.

---

It seems that having HtoA twice in HOUDINI_PATH is the culprit. (same thing happens with HtoA 5.4)

Message 7 of 14

If you double-click a hip file, that runs a different executable (eg on Windows, hview), and the environment is set differently (with the two entries that cause the problem)



// Stephen Blair
// Arnold Renderer Support
Message 8 of 14

How I can start Houdini with Houdini Command Line Tools step by step ??

Message 9 of 14
pablo_gazquez
in reply to: pal.mezei

It doesnt work for me 😞

Message 10 of 14

It's in the Windows Start menu, under Side Effects Software > Houdini > Utilities

Then run houdini or houdinifx or hindie



// Stephen Blair
// Arnold Renderer Support
Message 11 of 14

Stephen that was the problem, SUCCESS!!!!!!!!! I`m very happy 🙂


THANKS

Message 12 of 14

I have the same problem, I have tried everything and nothing works. I'm going crazy, I've been trying for a week. It's a very expensive product to have so many problems.

Message 13 of 14
biiiped
in reply to: Stephen.Blair

hello,

 

is there a way to change the env that is used by houdini when double-click on a file?

 

Message 14 of 14
biiiped
in reply to: willibarret2000

okay , so i removed one of the 2 path :

biiiped_0-1703232772449.png

and now it work , i can double click scenes and there is arnold nodes, i just try a bit, i don't know if this will cause other problem later, i hope this is the solution !



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums