Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows System Error #32

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
Thomas_Fleck
792 Views, 12 Replies

Windows System Error #32

Whenever i try to render the same scene over the teamrenderer the SECOND time i get the following message:

Allocate Space on Disk failed: file:///C:/Users/Admin/Documents/TeamRender_Temp/users/client/pv/tex/Backwall_1.jpg Cause: Windows System Error #32: Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.
(Non german: the process can’t access the file, becauset is used by another process)

To fix this problem i have to restart the client machine. For every render after the initial one. That sucks …

We use Macs to work in C4D and then send the final scene to our windows-machine.

Hope someone can help us out. I think this is a Windows related problem.

Labels (3)
12 REPLIES 12
Message 2 of 13

Is that a common issue with Team Render or does it happen only with C4DtoA? Single frame or animation?

Message 3 of 13

Single Frames and Animations. the first click on "render on team machines" always work, but when it has to send the same files again over the network i get the error message.

I will check tomorrow if this problem also exists with the standard renderer of C4D. Thanks for the tip!

Message 4 of 13

I could not reproduce the issue on my network. There's a Process Explorer tool for Windows where you can check which process locks the file:

https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

Go to Find > Find Handle or DLL. In the "Handle or DLL substring:" text box, type the path to the file (e.g. "C:\path\to\file.txt") and click "Search". All processes which have an open handle to that file should be listed.

Message 5 of 13

Thanks so much!
The problem isn’t solved, but i think we are one step closer.

The programm that is locking the file is the C4D Render Client itself. That also explains why it is working after a restart of the Render Client.

We are using C4D R16 and the windows machine is a freshly installed Win10.

Message 6 of 13

With the standard renderer from C4D the problem does not exist.
It only locks the file after the first rendering with C4DtoA.

Message 7 of 13

I can confirm it's C4DtoA who locks the texture after the render when the Auto-tile option is enabled in the Render Settings. It will be fixed in a next release.

However normally C4D creates a new folder with an index (e.g., pv, pv_0, pv_1, etc.) in the Team Render client repository when the previous folder still exists. Therefore multiple renders should run fine and does so on my system. I'm not sure why it does not work for you, but anyway, Arnold should release the texture and it will be fixed.

Message 8 of 13

The indexed folders (pv_01, pv_2) are created, but after the creation of the folder i get the error message. So the folders stay empty.
Unchecking the Auto-Tile option also doesn’t work. Restarted everything and updated all involved machines to the latest C4DtoA-Version.

Message 9 of 13

C4DtoA 2.1.1 has been released with the fix.

Message 10 of 13

Great News, but unfortunately we are on R16 at the moment.
I tried to install the R17 Version but it did not work (C4D didn’t start)

Is there any chance you could send us a compiled version for R16 Win+Mac? Would be so great 🙂

Message 11 of 13
Message 12 of 13

Installed and the problem is fixed 🙂
Thanks so much Peter!

Message 13 of 13

You're welcome! 🙂

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report