Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Volume mesher X fields X mix shader : impossible ?

13 REPLIES 13
Reply
Message 1 of 14
Pierre-Alexandre_Loy
525 Views, 13 Replies

Volume mesher X fields X mix shader : impossible ?

Hello,

I would to use a mix shader controlled by a field Torus on a volume mesher.

With a simple object, a vertex map created by Torus field controls my mix shader and it works.

For volume Mesher I used a Correction deformer to create a vertex map. Vertex map seems to be created like this but it doesn't work.

Any solutions ?

Screenshots below for a better understanding.

I join my file too. It's a R21 version.


Thank you for your help.


8134-01-mixshader-and-field.png

8131-02-mixshader-and-field.png

8132-03-mixshader-and-field.png


Volume_mesher_and_mix_shader.c4d.zip

Labels (3)
13 REPLIES 13
Message 2 of 14

The problem is, that the vertex map is not exported because it's not assigned to Volume Mesher directly. Add an Arnold tag to the Volume Mesher and specify the vertex map on the Export tab:

8085-volume-mesher-vertex-map.png

Message 3 of 14

Great ! it works !

Thank you very much Peter.

Message 4 of 14

Hum.. I've a new problem. Because now my Volume Mesher is animated, so Vertex Map seems buggy. I need to refresh it with each frame for it to work properly. This looks like a problem of UV and / or priority ... I don't know.

Screenshots and file below. Thanks for your help.

8127-animated-volume-mesher-01.png8128-animated-volume-mesher-02.png


Volume_mesher_animated_and_mix_shader.c4d.zip

Message 5 of 14

This problem exists only in the IPR, right? I'm not able to reproduce it. When I move the timeline I can see the wrong state, but when I release the mouse the IPR just renders correctly. I guess the plugin somehow does not recognize that the vertex map is updated and does not re-export it.

Message 6 of 14

I also have this problem when I made a render in the render queue. My real work scene has a much more complicated mesh, with more points.

Is it possible to bake the vertex map ?


Message 7 of 14

I can reproduce it in the render queue. I'm not convinced yet if it's the plugin's fault, could be a bug in c4d. I will investigate.

Don't think it's possible to bake the maps.

Message 8 of 14

ok Thank you.

I join my test from render queue to see bug.

test_cube_sphere.mp4.zip

Message 9 of 14

I can reproduce the wrong update of the vertex map in the Standard renderer as well, without Arnold, so it seems like an issue in Cinema 4D or maybe a wrong setup. I'll report it to Maxon.

Message 10 of 14

Ok thank you. Maybe a problem with Correction deformer in my opinion.

Message 11 of 14

Have you tried changing the Priority of the Vertex Map (Basic tab) to Generators? That seems to solve the problem for me.

Message 12 of 14

I think I had tried, without success. But indeed it seems to work with my simplified scene. i will try with my real working scene now.
Thanks for your help.

Message 13 of 14

I can confirm that it also works well on my big scene.
Thank you once again for your help and efforts.

Best

Message 14 of 14

Glad to hear everything's fine. Thanks for your feedback.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report