Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

too much motion blur - c4d

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
chris.holland7P2HP
389 Views, 6 Replies

too much motion blur - c4d

I want to add motion blur to shapes being emitted. No matter what I do to the settings, I get way too much motion blur. I've tried adjusting almost every setting I can possibly find (I have a very basic grasp on the sliders I must admit). But the funny thing is, no matter what I change in the settings, I get the same amount of motion blur.

At first I realised I was working to a very small scale, I thought that must have been the reason to my absurd amount of motion blur, but even after calling it I still had the same amount of motion blur... I'm pulling my hair out.


I've tried changing the shutter speed/angle in the camera

the length and position in my render settings

enable/disable camera checkbox in my render settings

enable/disable deformation checkbox in my render setting

adding/removing Arnold tag to camera in my render settings

scaling the scene up/down


Every single render - actual render, not IPR - is almost identical. With way too much motion blur...

I'm using C4D R20

Please help!!screenshot-2021-11-25-at-135453.pngscreenshot-2021-11-25-at-135413.png


Labels (3)
6 REPLIES 6
Message 2 of 7

Both, the length in the render settings and the camera shutter size in the Arnold tag should affect the motion blur effect. What type of simulation is this (C4D Emitter, X-Particles)? Can you share the scene?

Message 3 of 7

Thanks for the reply!

It's using a Standard emitter inside of C4D - emitting some basic shapes.

Here's a test file Motion blur.zip

I still get the exact same results, blown out motion blur that cannot be adjusted with any of those settings.

Message 4 of 7

ah, sorry - I didn't reply to your comment I posted my reply as an answer below.


Here's a render from the test scene I just sent to you:


screenshot-2021-11-26-at-115152.png

Message 5 of 7

When rendering motion blur, the plugin basically moves the timeline and exports the position of the particles in each keyframe. How many keyframes do we have depends on the Keys parameter, the Length defines the size of the window, the Position defines where the window starts. So a center motion blur of length 0.5 with two keys per frame looks like this:

motion-blur.png

Now the tricky part is to identify particles between frames. Particles have no ids in standard Emitter, so all we got is the particle order. If that changes between frames, which does in you setup with the Matrix object and Cloner, will mess up motion blur. It's a limitation I'm afraid.

You can try to increase the number of Keys to something like 5 or 9, change the position to 'start to frame' maybe, so that there are more samples and the particles don't mixed up. For instance I've got this with 9 keys:

motion-blur-9-keys.png

Message 6 of 7

How on earth you figured that out is beyond me. But thank you! Your render is 90% to where I'd need it, so I'm sure with some tweaking, I can get it to where I want with those base settings. Also, it's good to know that's a limitation; I thought I was going crazy...


Thank you so much

Message 7 of 7

If I add a rigid body tag to the cloner and cache, the motion blur works as it should with the usual settings working fine. Just in case someone else stumbles across this post.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report