Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Textures show red in Viewport

Message 1 of 15
2248 Views, 14 Replies

Textures show red in Viewport

sometimes some textures show red in the viewport. It can go away if fiddled around with shader settings and some luck. Does anyone have same problem?

I run
c4d r21.115

C4DtoA [9d6a6cbe]

Arnold core
Mac OS 10.15.3

Labels (3)
Message 2 of 15
in reply to: Anonymous

Red is the texture error color, so I would check the Arnold log. Something happened loading the texture

// Stephen Blair
// Arnold Renderer Support
Message 3 of 15
in reply to: Anonymous

This was reported before, seems like something has changed in Cinema 4D, and the textures are not loaded properly in the viewport sometimes when the scene loads. Only Mac is affected, R20 and R21. I'll ask Maxon again if it's something which has to be fixed on their side.

Message 4 of 15
in reply to: Anonymous

Hello Stephen, I have discovered the diagnostic tab. The file it produces when rendering is however 0kb. Do you have any tips on how to extract the error info?

Message 5 of 15
in reply to: peter.horvath6V6K3

It is very random, different textures are affected different times. Thanks for further investigating it.

Message 6 of 15
in reply to: Anonymous

Verbosity level is set to Warnings by default, which means only warning and error messages are written out. There's no error in Arnold currently, because your scene is fine, the problem is in C4D when the scene loads, so the file is empty.

Message 7 of 15
in reply to: peter.horvath6V6K3

Any news with the red texture display, Peter?
I tried to ask Maxon but they said this:

Hello Daniel,

We are very sorry, but we can't give you any support for thirdpaty plug-ins.
If you having issues with a plug-in, you have allways contact the developer directly.
The developer then, have to contact our development from his side directly over our developer support.
We are sorry for any inconvience.

Message 8 of 15

Yes, it's fixed and will be released soon.

Message 9 of 15

This should be fixed now in C4DtoA, please let me know if you still have issues.

Message 10 of 15
in reply to: peter.horvath6V6K3

it is fixed now, thank you for fast fix

Message 11 of 15
in reply to: Anonymous

i have the same issue

Message 12 of 15
in reply to: Anonymous

What's your C4DtoA and Cinema 4D version? Are you on mac?

Message 13 of 15
in reply to: Anonymous

I had this problem too (I'm not an Arnold user, btw). I found that, when I chose a material and set its reflection strength to zero, the red cast disappeared on that material. This made me think there was some glitch that makes materials think there is some bright red sky object that they're supposed to reflect. My scene had no sky object, and when I added a plain sky object (with no material) to my scene, the viewport problem vanished.

Message 14 of 15

I'm having the same problem in R21. For some reason, adding a sky object (with no material) instantly solved it. It seems that my scene's materials were attempting to reflect some phantom red texture, as if the scene had a solid bright red sky. In fact, my scene had no sky. Weird glitch. I don't like it.

Message 15 of 15

This sounds like a slightly different issue. In case of Arnold, it was a problem of c4d interrupting the viewport shader, thus the textures were not loaded correctly and displayed red.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report