Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Render glass shader solo whit alpha ?

32 REPLIES 32
Reply
Message 1 of 33
nezgro79
547 Views, 32 Replies

Render glass shader solo whit alpha ?

Hellon for my compositing scène i need to render juste a few glass tube solo , but if a render juste the tube whitout my background but whit my light , my tube are not trasparent . How can i fix it ?

32 REPLIES 32
Message 2 of 33
nezgro79
in reply to: nezgro79

whit file

1580-capture-decran-2018-05-23-a-022025.png

Message 3 of 33
Anonymous
in reply to: nezgro79
Message 4 of 33
nezgro79
in reply to: nezgro79

ok but my problem is if i activate background i have my transparency

Message 5 of 33
nezgro79
in reply to: nezgro79

like this

1582-capture-decran-2018-05-23-a-024454.png

Message 6 of 33
Anonymous
in reply to: nezgro79

Disabling the background if you are using Arnold Sky just put camera contribution to 0
if you are using a sphere with texture as a background it's normal that you get a black when you deactivate it. because you have nothing in your environment to reflect
here is a test with Arnold Sky Camera contribution=0

1584-withoutbg.jpg

and here with camera contribution=1

1585-withbg.jpg

Message 7 of 33
nezgro79
in reply to: nezgro79

how ok but i have a lighting setup whitout sky and if i put a sky my glass are not the same lighting of the rest of my scène

Message 8 of 33
Anonymous
in reply to: nezgro79

add arnold tag to your background and unchek primary visibility

Message 9 of 33
Anonymous
in reply to: nezgro79

with tag visibility ON

1587-tag-visibilityon.jpg

with tag visibility OFF

1588-tag-visibilityoff.jpg

Message 10 of 33
nezgro79
in reply to: nezgro79

Ok its work but is not transparant to make my compositing working

1586-capture-decran-2018-05-23-a-033111.png

Message 11 of 33
Anonymous
in reply to: nezgro79

To get transparency you must add arnold tag with opaque unchecked
You have 3 bottle facing the camera, aligned one behind the other two, each bottle must have at least 4 rays, so 4*3 = 12
So set transmission value to 12 in Render Setting/Ray Depth

Message 12 of 33
nezgro79
in reply to: nezgro79

same again 😞

1589-capture-decran-2018-05-23-a-114025.png

1590-capture-decran-2018-05-23-a-114010.png

1590-capture-decran-2018-05-23-a-114010.png

1591-capture-decran-2018-05-23-a-114154.png

Message 13 of 33
lee_griggs
in reply to: nezgro79

Can you show your shader settings. Does it have Transmission?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 14 of 33
nezgro79
in reply to: nezgro79

I try this !

1593-capture-decran-2018-05-23-a-121327.png

Message 15 of 33
lee_griggs
in reply to: nezgro79

What happens when you increase Transmission Depth?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 16 of 33
nezgro79
in reply to: nezgro79

nothing 😞

Message 17 of 33
nezgro79
in reply to: nezgro79

in the after effect project my glass is not transparaent and dont show my rhino

1594-capture-decran-2018-05-23-a-122004.png

Message 18 of 33
lee_griggs
in reply to: nezgro79

Can you post a simplified scene?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 19 of 33
nezgro79
in reply to: nezgro79

ok try to export the glass in after effect and put another layer behind it 😉

Thank you my friend

[url=https://www69.zippyshare.com/v/Z1q93KYn/file.html]forum.zip[/url]

Message 20 of 33
lee_griggs
in reply to: nezgro79

That link doesn't work. Can you post it somewhere more reliable, please?

Lee Griggs
Arnold rendering specialist
AUTODESK

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report