Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

relativ path with procedural, export problems

4 REPLIES 4
Reply
Message 1 of 5
Anonymous
261 Views, 4 Replies

relativ path with procedural, export problems

hey guys,

i have a export problem with my procedurals: i distributed the procedurals, used only the object name in the path field and set the searchpath in the rendersettings. after this i want to export the scene-ass and render it with kick on a farm. i change the system searchpath with the kick command -set options.procedural_searchpath "/newpath/"

with a small amount of procedural everything work fine, but if i increase the numbers of the procedurals (maybe 1000) the export process took very very long time now. if i change the procedurals to an absolut path it woks fast, but than i lost the possibility to change it easy during the render process.

any idea why this problem happend and why it needs more time to export with relativ paths? or is there an other solution for this problem?

i use c4dtoa 2.3.1.3 and don't want update to 2.4 until this project is finished.

thanks a lot!!

marc.

Labels (3)
4 REPLIES 4
Message 2 of 5
peter.horvath6V6K3
in reply to: Anonymous

Normally having absolute or relative paths should not make any difference. I'll try to reproduce it on my machine. Are those procedurals referencing the same ASS file or are they all different?

Message 3 of 5
Anonymous
in reply to: Anonymous

hi peter,

thanks for your answer!

thay are referencing the same ass file. i prepared a scene, were you can see the problem. maybe you can have a look at this:

http://marc-angele.ch/arnold_answer/

thanks!

Message 4 of 5
peter.horvath6V6K3
in reply to: Anonymous

The plugin tries to resolve the relative path during export, meaning it checks if the file exists in any of the folders from the search path. This I/O gives an overhead. The difference is not noticable on my machine with your scene (it's about 0.5 sec), yet I imagine it could be more significant, for instance if the folder is on a shared drive, etc.

I'm not sure yet how to properly fix this, because some parts of the code needs the absolute path.

Since all procedurals reference the same ASS file, a workaround could be using instances, instead of duplicating the procedural object.

Message 5 of 5
Anonymous
in reply to: Anonymous

hi peter,

thank you so much for your answer and that you tested my files.

i tried a lot with different drives (local and shared), with different files and scene, but nothing worked.. the export took with abolut path a few seconds and with relativ path up to 4-5 minutes.

then a switched to a windows machine and booom, the export works! so i export now my scene on this windows machine, but i have no idea what is wrong with my mac.

any way, now i have a workaround. thank you again for your time!

best marc

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report