Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Recently updated from C4DtoA 2.3.1.3 to latest build 2.4.1.2 ---- Z Depth Pass appears to be broken?

2 REPLIES 2
Reply
Message 1 of 3
akehurstm
326 Views, 2 Replies

Recently updated from C4DtoA 2.3.1.3 to latest build 2.4.1.2 ---- Z Depth Pass appears to be broken?

I've recently updated from C4DtoA 2.3.1.3 to the latest build 2.4.1.2


Opening a project with a Z AOV returns a white on black 'mask' image in the IPR - and the EXR return pure white when extracted in After Effects (Levels adjustment in a 32bit comp reveal noting but a spike at the very top end of the range).

I've got the exact same project open on a second machine running 2.3.1.3 and both IPR and EXRs are returning expected results. (Extracted files in After Effects producing the expected range of depth)

Both machines are running C4D R18.057

Mac OS Sierra (10.12.6)


On the 2.4.1.2 build I've tried copying all assets to a fresh project/fresh Arnold Render settings - but still experiencing the same result.

I'm pretty new to Arnold - so apologies if I'm asking a 'face palm' of a question!

Thanks for your time!

arnold-2-4-1-2-z-pass.pngarnold-2-3-1-3-z-pass.png


Tags (3)
Labels (3)
2 REPLIES 2
Message 2 of 3

I don't see any difference between those two versions related directly to the Z AOV. The Z AOV contains the absolute distance from the camera, so you need a 32-bit output image format. You see a black and white mask in the IPR, because it displays an 8-bit image, so objects further than 1 unit are all white. It can be grayscale if your scale is small and your objects are all closer than 1 unit.

I'm not exactly sure why your Z passes are different. There was a change regarding how scene length units are exported to Arnold, maybe it's something to do with that. If you can send me your scene, I can take a look.

Message 3 of 3
akehurstm
in reply to: akehurstm

Thanks for the response Peter!

Both versions of the project had scene scale set to 1, and were set to output 32bit EXR.

But after you mentioned the scene length units changing on export I jumped back in to the 2.4.1.2 project and dropped the scene scale down to 0.1 - this rectifies the issue and gives me the greyscale range I was seeing in the EXR produced by 2.3.1.3.

Cheers again for the help!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums