Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

problem with Xparticles Trails rendering with arnold

5 REPLIES 5
Reply
Message 1 of 6
Anonymous
243 Views, 5 Replies

problem with Xparticles Trails rendering with arnold

Hi There !

Got a small problem here, must be a bug between C4dtoA and XP. When trying to render a large amount of trails, using the Arnold Tag, depending on XP Trails spline interpolation mode, a large amount of trails can be missing.

ie with no interpolation or Adaptative there is no problem, but when switching to Natural or Uniform, lots of trails disappear from the IPR.

here is a simple scene to evaluate the problem :

trails_test.zip


(btw somebody should authorize *.c4d as attachment on this forum, as it's a Arnold/c4d forum x) )

Tags (2)
Labels (2)
5 REPLIES 5
Message 2 of 6
peter.horvath6V6K3
in reply to: Anonymous

Thanks for the scene, I can reproduce the issue. Will take a look and let you know.

Message 3 of 6
peter.horvath6V6K3
in reply to: Anonymous

I think this is a limitation in XP. From the manual:

Important: do not subdivide the spline (i.e. you should leave intermediate points as 'None') if you want to use the spline renderer to render the trail. Using intermediate points will cause the spline renderer to ignore the thickness setting and the colour. This is currently a limitation of the system.

That's what I'm seeing, Arnold exports the generated Spline and the thickness and color information is not there. I'll ask Insydium support to be sure.

If you use 'None' or a custom thickness in the Arnold Tag, then the curves are rendering fine.

Message 4 of 6
Anonymous
in reply to: Anonymous

Oh ok !! didn't read that information ! so yeah in fact as Adaptative somehow works I can get my splines to works correctly too and have them in good interpolated/curved shape while keeping thickness driven by the XP system. But yeah I'll keep that in mind for the future !

Thanks a lot for looking at it !

Message 5 of 6
peter.horvath6V6K3
in reply to: Anonymous

Note, that Adaptive does not work correctly either, if you try to use the thickness and color coming form XP.
Message 6 of 6
Anonymous
in reply to: Anonymous

somehow it seems to render correctly the test setup I sent on adaptative with thickness related to particles radiuses with a bit of random (but maybe that's out of luck here 😉 and if I pay attention, it seems that the smallest trails are not rendering in fact)trails.jpg but yeah i'll keep in mind that If i want to render trails according to some XP parameters I'll work with no spline interpolation ! (that's good to know ! )

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report