Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Peculiar memory leak in C4DtoA 2.3.0.1

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
Anonymous
458 Views, 2 Replies

Peculiar memory leak in C4DtoA 2.3.0.1

I was recently working on some shader related stuff for Arnold 5 and came across a peculiar bug in C4DtoA.

The weird thing is that I've not been able to replicate these results in any other scene, however the scene in question seems to demonstrate the bug 100% of the time. Upon rendering to the picture viewer, Arnold will blow through my RAM almost instantly (all 32GB of it) and begin to swap out to disk. Originally I thought my own code was at fault, however I tried removing all my custom shaders and stripping down the demo scene to the bare basics- just a couple of area lights and a sphere, and it's still doing the same thing.

Anyways, I figured someone at SolidAngle might want to know about this. The scene in question is attached.

Cheers,

-CMPX

PS: I am currently running C4D R17.055 on Mac OS X 10.8.5 with C4DtoA 2.3.0.1 on a 12-core 2.93ghz Mac Pro.

memleak-c4d.zip

Tags (2)
Labels (2)
2 REPLIES 2
Message 2 of 3
peter.horvath6V6K3
in reply to: Anonymous

The extreme memory usage is caused by the progressive render, which you have enabled in the User Options of the render settings. Note, that it is currently an experimental feature in an unoptimized state (that's why it's not exposed in the render settings).

Message 3 of 3
Anonymous
in reply to: Anonymous

I kinda figured that was the problem, but I've been unable to reproduce that behavior in a freshly created scene. I figured that since I was able to capture the glitchy scene in a reproducable state, it might be of some use to someone since it sounds like progressive rendering is still being worked on.

Thanks for the response though!

-CMPX

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report