Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Odd blur of bitmap through glass object

8 REPLIES 8
SOLVED
Reply
Message 1 of 9
shawn
475 Views, 8 Replies

Odd blur of bitmap through glass object

In creating a scene of a car on a highway I encountered an artifact I can't pin down in which the bitmap I've applied to the highway texture receives an odd blur.

In this render of a simplified scene I have a strip of transparent polygons running across the frame. No roughness, Thin-walled geometry, IOR 1.59. Note that the cube isn't being blurred, just the highway texture near the top edge of the glass strip:


4823-weirdglassblurrender.jpg

In this render of the same scene I've replaced the highway bitmap with procedural stripes made with the Checkerboard texture. No blurring is visible here:

4824-weirdglassblurrender-checkerboard.jpg

Am I missing a checkbox or setting somewhere? Here's the R20 scene file:

https://www.dropbox.com/s/s3e5f1j2oplqooa/WeirdGlassBlur.zip?dl=0

Thanks!

Shawn Marshall

8 REPLIES 8
Message 2 of 9
thiago.ize
in reply to: shawn

This is very likely due to the texture differentials being used.

I don't have c4d, so can't try out your scene, but one quick thing you can try on your end is to toggle the global options texture_conservative_lookups from true to false. While that will result in more texture memory usage, it might fix this. If it doesn't, then it's probably a bug in Arnold we need to fix.

Message 3 of 9
shawn
in reply to: shawn

Hi Thiago:

Thanks for the reply. I don't know how you toggle the feature you've described to FALSE. I'm guessing it's a Terminal thing, and I generally avoid touching the Terminal. I can't find step-by-step instructions to do what you've described.

I've found a workaround that will suffice for now. If I use the native Arnold Image texture node (I'd been using the C4D bitmap node to bring in my highway image) and set its Mip-mapping bias to -8 the blur will be reduced to an acceptable level. I'll have to animate that value back down to 0 when I fly my camera out of the car to an omniscient perspective.

Cheers.

Shawn

Message 4 of 9
Stephen.Blair
in reply to: shawn

In the Render Settings, Diagnostics tab.

Put this in the User Options:

texture_conservative_lookups  off



// Stephen Blair
// Arnold Renderer Support
Message 5 of 9
shawn
in reply to: Stephen.Blair

That did the trick, thanks so much! I did do a Google search for "global options texture_conservative_lookups arnold", but it didn't point me to that Diagnostics tab.

Cheers!

Shawn

Message 6 of 9
thiago.ize
in reply to: shawn

Glad that worked! If you're happy with the solution, can you please mark this question answered?

Message 7 of 9
shawn
in reply to: thiago.ize

This will sound pathetic, but I spent several minutes yesterday and several just now looking for an obvious "question answered" button, and I cannot find it.

Message 8 of 9
thiago.ize
in reply to: shawn

Here's what the user guide says:

When you get an answer that helps you solve your issue, be sure to click the checkmark box to mark the answer as accepted. This tells others that the answer helped solve the problem and it tells moderators that the question was resolved.

I don't own any questions myself, so I don't know what it looks like now. Arnold Answers was recently upgraded, so it might be this functionality is missing? We'll reply back once we know what's up.

Message 9 of 9
shawn
in reply to: thiago.ize

This interface in NOT intuitive. Stephen answered my question in the form of the Comment, and there's no "ACCEPT" link to click in the Comment format. So I just clicked ACCEPT on your first answer, which was essentially the issue but didn't specify where to fix it.

Thanks!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators