Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Alpha Mask in UVW_Mapping - cutout opacity

6 REPLIES 6
Reply
Message 1 of 7
vockC3F3P
363 Views, 6 Replies

No Alpha Mask in UVW_Mapping - cutout opacity

Hi guys.

I would like to have an AOV for a tree.

The Material for the leaves is with a cutout opacity JPG (B/W) Image. The Projection is in UVM on a square Polygon.

Now, if i render the AOV the Polygone is masked but as a square wihout the cutout. In flat mapping the AOV is rendered with the cutout.

I tried everyting from:

uncheck opaque

transmit AOV in Transmission (though i dont use it...)

color correction with alpha is luminance

...

 

Maybe some one has the answer to this problem?

I believe in earlier Arnold versions this was never a problem.

 

Best,

Marc

 

Cinema 2024

Arnold 4.6.8

6 REPLIES 6
Message 2 of 7
peter_horvath
in reply to: vockC3F3P

Sorry for the late reply. What does it mean having an AOV for the tree? Are you using an aov_write shader? Could you share a simple scene that shows the problem?


// Peter Horvath
// C4DtoA developer
Message 3 of 7
vockC3F3P
in reply to: vockC3F3P

Hi Peter

Thank you for your Reply.

I have a Testfile to share.

I use an Object mask tag or the custom AOV tag with a Material in it.

Usually the Object Mask tag worked.

 

Best,

Marc

Message 4 of 7
peter_horvath
in reply to: vockC3F3P

Ok, I see now. Something's definitely wrong, but seems to be IPR only. If I render to the Picture Viewer, the cutout renders fine in the AOV. Can you confirm that?


// Peter Horvath
// C4DtoA developer
Message 5 of 7
vockC3F3P
in reply to: vockC3F3P

I did a render with the render manager and with the custom AOV it works but with the normal object mask it stil ldoesn't work. . But I encountered an other problem. If your scene has a lot of Objects (scatter object - Gras) it also does not work with the custom AOV. 

Message 6 of 7
peter_horvath
in reply to: vockC3F3P

It is definitely a bug with the Blend opacity flag of the object mask/custom AOV and the IPR. But final renders (render to Picture Viewer) should be fine. Make sure you have the Blend opacity checkbox enabled and you render on the CPU. Unfortunately blend opacity is not supported on the GPU at the moment.

Having lots of objects should not be a problem, but could be somehow related to this bug. In my quick test scattering the leaves worked fine in the Picture Viewer.


// Peter Horvath
// C4DtoA developer
Message 7 of 7
vockC3F3P
in reply to: vockC3F3P

thank you for looking into it.

The bug with lots of scatter object is visible in the IPR and when rendering via render manager. When i switch the scatter off it renders correctly.

thx for the hint with CPU and GPU.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report