Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Motionblur not working on xparticles generated objects

Message 1 of 6
814 Views, 5 Replies

Motionblur not working on xparticles generated objects

Hi. I have created some xparticles that rotate dynamically. I then used x- generator to instance a simple piece of geometry on them.

When I render this out the instanced geo doesnt ever recieve motion blur. Either in motion vectors or using 3d motionblur I cant seem to get the motionblur to come through.

Has anyone solved this issue? I included a sinppet of the render I have. The sphere is just a primative with an animation to test the motionblur. The objects in the background are moving very fast and should have a good deal of motion blur on them but are getting none.

I tried applying an arnold tag to the object and enabling motionblur there and that didnt work.

Any ideas hot to solve? Thanks


Tags (1)
Labels (1)
Message 2 of 6
in reply to: Anonymous

I set up a scene that I think is close to what you did and I'm getting motion blur on the geometry and didn't have to apply the Arnold tag... scene file attached if you wanna inspect it


Message 3 of 6
in reply to: Anonymous

hmm. I attached my scene as well. I am using an explosia simulation and advection to drive the movement of the generated particles. Could something getting lost in that translation be the issue?

Message 4 of 6
in reply to: Anonymous

I've been having a hard time getting it to render (dense scene and I'm on beefy hardware)... I did notice that the scene defaulted to GPU, is that what you were using? Have you tried switching to CPU and see if that works?

Message 5 of 6
in reply to: Anonymous

It seems to me like a bug (limitation?) in the xpGenerator. It works like a Cloner, it creates polygon objects and instances in the object cache which are read by C4DtoA and exported as they are. When rendering motion blur, C4DtoA moves the timeline and exports the scene in each motion key (subframe). Seems like the render instances are not updated properly in sub-frames when instanced with a Cube primitive. I had to do two things to make it work:

1. Turn the Cube to a polygon object (Make Editable - C)

2. Disable 'Update on Frame change Only' in the xpGenerator

Message 6 of 6
in reply to: peter.horvath6V6K3

Thankyou Peter 🙂

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums