Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Loading c4dtoa (r20) from centralized network location // crash

16 REPLIES 16
Reply
Message 1 of 17
calle.thor
427 Views, 16 Replies

Loading c4dtoa (r20) from centralized network location // crash

Hi,

We use a centralized network location to load all our plugins. Prior to r20 this location was set as an environment variable (C4D_PLUGINS_DIR). Now in r20 this variable is skipped and you can instead set multiple plugin locations in the c4d preferences.This is great, apart from the fact that Cinema crashes on startup when c4dtoa is present in this server folder. Using the latest version of both c4d (r20.030) and c4dtoa (2.4.2.1). Other plugins load when c4dtoa is removed. If installed in the default plugins dir, c4dtoa is loading as expected.

Would be great if you can have a look at this as we really prefer to have a shared plugin path for our plugins as it makes it soooo much more convenient to keep track of versions and updates among all workstations and rendernodes.

Cheers,

16 REPLIES 16
Message 2 of 17

Is it Windows? I had a similar report recently, but I could not reproduce it. I guess because I used the g_additionalModulePath environment variable and not the Preferences. If I set the path in the Preferences, I've got the crash. I'm looking into it. Meanwhile can you check if the env var works for you?

Message 3 of 17
calle.thor
in reply to: calle.thor

Thanks!!!

That works great. I actually prefer this method. Do you know if this is a new env variable introduced in r20?

Thanks again, great support! @Peter Horvath

Message 4 of 17
calle.thor
in reply to: calle.thor

Whoops, my bad. Still crash. Had it installed locally as a workaround and thats why it seemed to load from server.

Message 5 of 17

Hmm, interesting. Anyway, I'll try to fix this for the upcoming release.

This is a new variable, yes. Check out the online documentation for all env vars:

https://help.maxon.net/us/#11083

Message 6 of 17
calle.thor
in reply to: calle.thor

Thanks @Peter Horvath

Here's the cmd output

CRITICAL: Stop [ge_win_window.cpp(1396)]
Error: application crashed
C4DUnhandledExceptionFilter: writing exception info
C4DUnhandledExceptionFilter: writing call stacks

Have a crash log and dump if needed.

Cheers

Message 7 of 17

No need for the log, thanks, I already have the fix. Please try this build. Preferences and the env var, both should work.

https://safeshare.solidangle.com/index.php/s/0dhdOxRfN4Y8Mlc

password: 4t7qFc

Message 8 of 17
calle.thor
in reply to: calle.thor

Thanks! Will test after the weekend!

Have a great one!

Cheers,

Message 9 of 17
calle.thor
in reply to: calle.thor

Hey,

Just had a go at it but unfortunately, it still crashes. Both prefs and env. var.
Loads fine installed locally.

Cheers,

Message 10 of 17

I'm pretty sure it worked for me. How do you specify the path? I think I've tested with a mapped drive.

Message 11 of 17
calle.thor
in reply to: calle.thor

Ok, hmmm.

Do you map it by assigning a drive letter? (map network location) So your path is X:\\server\path\to\plugins?

I've pointed the path simply \\server\path\to\plugins. As all machines are on the same domain with credentials setup this works in other cases. Have tried both as user env var & system env var just in case. Using the r20 prefs way, dragging the desired network folder straight into the prefs yields the same path. ie, no drive letter. Guess I could try by assigning a drive letter but really like to avoid mapping this drive on each computer individually.

We use Deadline and one major advantage is that you can sideload an env var along with the job submission. This way we don't even have to set the env var on every render node individually. Its created with the render task.

The test that I have done this far is on my workstation though & setting the env var through system settings.

I still have the old C4D_PLUGINS_DIR active as we need r19 for a transitional period. Could that be an issue?

Message 12 of 17

I've tried with a network driver, but of course the network path (\\server\whatever) should work as well. And indeed it crashes. I guess I know where the problem is.

Message 13 of 17

I've uploaded a new build (2.4.2.2_wip03). Could you please give it a try before I release it?

Message 14 of 17
calle.thor
in reply to: calle.thor

Thanks! Will do!

Message 15 of 17
calle.thor
in reply to: calle.thor

Awesome, it works! Thanks, great support.

Message 16 of 17

Great, thanks or the feedback. Will be released soon in 2.4.3 (I hope today).

Message 17 of 17

C4DtoA 2.4.3 is released, containing the fix. Thanks for the feedback.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report