Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Increasing dynamic range in renders

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
Tim_Anderson1
948 Views, 12 Replies

Increasing dynamic range in renders

I have been struggling with Arnold renders clipping badly – in order to get enough light I am having to increase light exposure and my highlights end up blown out.

I read a post about increasing the dynamic range in renders for Blender (https://www.blenderguru.com/tutorials/secret-ingredient-photorealism). This post mentioned the "Filmic Blender" colour configuration, which looks to be based on ACES. I assume this is the same path I need to follow for c4dtoa.


1. Base test

Here's a test render illustrating the issues I'm seeing, this uses the default 'color manager' settings:

7988-base-built-in-color-mgmt.jpg


2. Trying to setup ACES

I've tried to figure out how to get ACES working with c4dtoa – but I am failing. I have followed this post (https://cglines.blogspot.com/2020/05/how-to-aces-in-c4dtoa.html) loading, the ACES config:

7989-screen-shot-2020-08-21-at-42946-pm.png

but my output with these settings seems no better or different to the default test (am I missing a step after setting the ACES config?):

7990-base-aces.jpg


3. Using 'Blender Filmic'

I have tried loading the 'filmic' configuration, which was created for Blender, I assumed it would not work...and I couldn't really get it to do anything. However, I loaded the configuration and tried different selections and somehow got this result, which in terms of highlights and range is just what I'm after (although some textures are rendering incorrectly) – the problem is that I got this render to work, but I cannot replicate it, the config seems flaky and won't load and I cannot reliably replicate this output:

7986-base-blender-color-mgmt.jpg

In short, is there something I am doing wrong in loading the colour manager config – it doesn't seem to be doing much, or it's flaky and I can't get the settings to stick.

Alternatively, am I barking up the wrong tree in trying to fix the dynamic range of my renders?

Tags (2)
Labels (2)
12 REPLIES 12
Message 2 of 13
lee_griggs
in reply to: Tim_Anderson1

Are you rendering to EXR?


>I have followed this post loading, the ACES config:

This link does not work. Are you referring to this ACES page?


>(am I missing a step after setting the ACES config?):

This?



Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 13
Tim_Anderson1
in reply to: lee_griggs

Sorry, link I followed for ACES setup was this post:

https://cglines.blogspot.com/2020/05/how-to-aces-in-c4dtoa.html

Does changing the IPR window Color Space affect the render?

Message 4 of 13
lee_griggs
in reply to: Tim_Anderson1

Yes. Did you do this?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 5 of 13
lee_griggs
in reply to: Tim_Anderson1

https://www.youtube.com/watch?v=4cCQ3pTRfmU

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 6 of 13
Tim_Anderson1
in reply to: lee_griggs

I did. However, I've just noticed that the console is returning this

color_manager_ocio] color spaces will be ignored due to rendering color space OCIO error (Could not find colorspace 'BT.1886 EOTF'.)

I am assuming this is why I have no change when loading ACES.

Message 7 of 13
lee_griggs
in reply to: Tim_Anderson1

Did you remove any files from the OCIO folder?

Did you follow the steps in the video?

https://www.youtube.com/watch?v=4cCQ3pTRfmU

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 8 of 13
Tim_Anderson1
in reply to: lee_griggs

I re-downloaded and now I get no errors, and I've followed the steps in the video. Thanks for your tips...but I am still not seeing any difference between a render with color manager set to ACES vs sRGB – but I do see the difference in the IPR.

I'm just not sure whether I'm missing a key step. I'm outputting to EXR, am I wrong to assume the histogram should be different between the two in the picture viewer?


Message 9 of 13
Tim_Anderson1
in reply to: lee_griggs

Here's results with default settings –

7991-screen-shot-2020-08-22-at-122616-am.png

ACES test – render/histogram unchanged, IPR seems to be correct

7992-screen-shot-2020-08-22-at-122717-am.png

My test file: https://www.dropbox.com/s/txs438iol884w39/ACES%20Test%20v2.c4d.zip?dl=1

Message 10 of 13

Your selected output color space (Output - sRGB) is applied only in the IPR window. The Picture Viewer applies the native sRGB color space transform over the render output.

The recommended workflow is to output to EXR which is in the render color space and apply the ACES output space in post. Or use an Arnold driver where you can select the ACES output space.

Message 11 of 13

Ah, got it. Thank you very much.

Message 12 of 13

I'm not seeing any difference between a render with color manager set to ACES vs sRGB – but I do see the difference in the IPR. Perhaps I'm missing a key step. I'm outputting to EXR, am I wrong to assume the histogram should be different between the two in the picture viewer?

Here's results with default settings –

7991-screen-shot-2020-08-22-at-122616-am.png

ACES test – render/histogram unchanged, IPR seems to be correct

7992-screen-shot-2020-08-22-at-122717-am.png

My test file: https://www.dropbox.com/s/txs438iol884w39/ACES%20Test%20v2.c4d.zip?dl=1

screen-shot-2020-08-22-at-122616-am.png (1.5 MiB)screen-shot-2020-08-22-at-122717-am.png (1.6 MiB)
Message 13 of 13

As I said before, the ACES output color space transform is only visible in the IPR. If you render to the Picture Viewer, you will see the native sRGB transform added by Cinema 4D. (Unfortunately Cinema 4D does not support ACES).

If you want an output image with the ACES output space applied, then you can not use the native Sae option. Instead create an Arnold Driver (e.g. tiff) and set the color space there.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums