Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

I want to use the Arnold Driver with Cinema's TeamRender

14 REPLIES 14
Reply
Message 1 of 15
JeffreyTD_Shosho
672 Views, 14 Replies

I want to use the Arnold Driver with Cinema's TeamRender

Hi All,

I just cannot seem to get this working..! I want to use the Arnold Driver with all its settings; set a custom output path and render via the TeamRenderer. I set the output in C4DtoA render settings to "Arnold drivers only (no output)". I get a handful of 10KB exr frames in the appropriate spot before the whole thing quits on me.

"(Error) Render-Job failed: Saving failed." for all of my clients. We need to to go via this route because of numerous reasons.

what to do? Exporting an .ASS sequence and going via our other render manager takes too much time at this point.

any help or tips and tricks are much appreciated ๐Ÿ™‚

Tags (3)
Labels (3)
14 REPLIES 14
Message 2 of 15

In contrast to the native Save, the Arnold drivers are executed on the client machines at the end of the render process. Make sure the output path defined in the scene is accessible by each client (e.g. network drive with the same path). If you have a mixed system (win and mac) you can use an environment variable in the driver output path as a prefix and define the variable on each client. Something like ${MYENVVAR}output.exr.

Message 3 of 15

Hi Peter,

It's a mapped network drive and all machines can access it. For now I'm using windows only... As you can see I do get output on the correct spot but they are 10KB empty frames and I get an error afterwards.

The same happens when we do this on OSX.

Message 4 of 15

Does the native Save in the same scene work fine? Are there any warnings or errors in the Arnold log? What if you use a valid output format instead of the dummy "Arnold drivers only (no output)" while keeping the drivers?

Message 5 of 15

- Native Save works fine.
- Valid output also works

The problem is that:

A: using this method gives incorrect and incomplete metadata so the files are unusable in Nuke.
B: We would like the option to use the variance AOV driver for future denoising. this also only works via the Arnold Driver.

Message 6 of 15

I understand why you need the Arnold drivers, I just wanted to know if the error is related to Arnold or not. The error message you posted is a C4D error which is thrown when C4D can not save the file which could be an issue in C4D or in the Arnold driver. Please check the log of the clients, it should give you a detailed error message if it comes from the Arnold driver. So far the only way I could reproduce this error is to specify an invalid path in the driver, otherwise Team Render works for me.

Do you have the same error in any simple scene (e.g. a sphere with a light)?

Message 7 of 15

And which version of C4D and C4DtoA do you use btw?

Message 8 of 15

Gotcha,

I will try a simple scene.

3724-zucht.jpg

I pulled logs from one of the clients:

It seems to be texture related...But I don't get these errors when I render via the C4D output.

We're using C4DtoA 2.5.0.1 and Cinema4D R20.057 (build RB269127)

Message 9 of 15

That must be it, seems like the texture is not downloaded correctly. Textures should be automatically transferred to the clients, you should see a log entry, like 'Created Asset' with the texture name, that means it was downloaded from the server. Maybe it's something with the auto tx generation or unicode character in the texture name. I'm just guessing here.

Message 10 of 15

I'm trying out a simple scene without textures and this is working as expected... I still find it odd that through native save it does work. I will check texture names and tx settings and all that :). I'll report back

Message 11 of 15

Indeed, that's odd, native Save should not make any difference in finding the texture.

Message 12 of 15

I had a few textures that were not yet converted to .tx. I was under the assumption that all of them were; so "auto-convert textures to TX" was unchecked. So I unchecked "Use existing .tx textures" as well and everything worked.

Thanks for thinking along Peter. Note to self: triple check your texture setup before team rendering :).

Message 13 of 15

Great, I'm glad you've found the problem.

Message 14 of 15

Hi, I'm having the same issue as Jeffrey. Can you clarify further how to "define the variable on each client"? Thanks.

Message 15 of 15

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report