Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How do I use z-depth AOV passes from Arnold within Adobe After Effects?

11 REPLIES 11
SOLVED
Reply
Message 1 of 12
ben.fischler
15601 Views, 11 Replies

How do I use z-depth AOV passes from Arnold within Adobe After Effects?

Can someone break down the steps to use Arnold z-depth passes in After Effects?

Labels (4)
11 REPLIES 11
Message 2 of 12
dadeFC4BK
in reply to: ben.fischler

Getting z-depth AOV passes from Arnold within AE is actually quite simple. Generally I always render either full or half-precision .exr files. If I plan on using them in AE. I never combine the passes into a single multi-channel .exr and always simply render out each AOV as an individual .exr sequence. AE can extract channels from multi-channel .exr files, but it can make things very slow, so individual sequences work better IMHO.

Set up your AOVs as you usually do in Cinema 4D and leave the z-depth setting at its default setting. I’m not going to get into whether anti-aliased or aliased depth passes are better, but for my uses aliased always works better which is default. If you rather have z-depth passes anti-aliased, simply change the Filter Type from closest_filter to gaussian_filter.

14-z-depth-passes-process-001.png

Once you’ve rendered out the .exr sequences, import them into AE as you usually would. Set your project to either 16 bit or full 32 bit, either will work, it just depends on how you need or want to work. Now create a new comp using the z-depth AOV sequence that you previously rendered. Don’t worry, it will appear either pure white which is fine… there’s plenty of information in those seeming empty pixels. Now follow the steps listed below:

  1. Add a EXtractoR filter to the newly created layer. Effect>3D Channel>EXtratoR. The layer will immediately turn black, which should be expected.
  2. Now click on any of the Channel Info colors. This will bring up the dialog that will allow you to assign the correct ‘layer’ to all of the channels.
  3. You’ll notice that there’s only one layer labeled Y. I believe this is luminance, but it doesn’t matter… it’s the only one available and it works. So go ahead and assign the Y layer to all the different channels: Red, Green, and Blue. You don’t need to worry about Alpha, it doesn’t make a difference. Now click OK. The layer will now turn pure white again.
  4. You’re now you’re ready to adjust your z-depth channel. Find the Black Point spinner in the EXtractoR filter and simply begin raising it by increments of 10 until you get something you’re happy with. The amount will depend on the size of your scene, and in some cases with very small scenes, it can be very sensitive. I’m sure there’s some exact math around this, but I usually simply try to get every object in the scene to be visible within the image and then use a Levels Adjust to exaggerate or subdue the effect.
  5. You now have a perfect z-depth sequence to use with your favorite DOF plugin (I’m still using Frischluft after all these years).

    15-z-depth-passes-process-002.png

Message 3 of 12
tlfiction
in reply to: ben.fischler

Thank you for the tip, this works great 🙂

Message 4 of 12
1588910
in reply to: ben.fischler

Thank you for your answer. It was very useful and solved my troubles. But I had a problem with the production of this step, the z-depth is not smooth, I tried many times, including setting the ae project to 32-bit still did not solve the problem.@Dade Orgeron

1659-未标题-1.jpg

Message 5 of 12
dadeFC4BK
in reply to: ben.fischler

I wouldn't worry about the gradient banding you're seeing in the viewport. This is usually more of a display artifact and in my experience never causes issues once used either as a depth buffer or fog layer. If you plan to use it as is, simply add a tiny bit of grain to help reduce the amount of banding.

Message 6 of 12
1588910
in reply to: dadeFC4BK

Thank you all so much.Solved my big problem。thankyou !

Message 7 of 12
hi2AY29
in reply to: ben.fischler

Can i render Z depth as png sequence? i've tried but i didn't get any data on the Z layer. and i don't want to render .exr because the frame size is massive! any solution?

Message 8 of 12
Sunny_Suppy
in reply to: ben.fischler

Why does this issue exist from 2015 to now and still NOT even be fixed ? There is no different from closest vs gaussian filter on Zdepth AOVS !!!!!! It's still very very jagged. Please fix !!!!

Message 9 of 12
Sunny_Suppy
in reply to: ben.fischler

Why does this issue exist from 2015 to now and still NOT even be fixed ? There is no different from closest vs gaussian filter on Zdepth AOVS !!!!!! It's still very very jagged. Please fix !!!!

Message 10 of 12
Sunny_Suppy
in reply to: ben.fischler

Why does this issue exist from 2015 to now and still NOT even be fixed ? There is no different from closest vs gaussian filter on Zdepth AOVS !!!!!! It's still very very jagged. Please fix !!!!

Message 11 of 12
Sunny_Suppy
in reply to: dadeFC4BK

Why does this issue exist from 2015 to now and still NOT even be fixed ? There is no different from closest vs gaussian filter on Zdepth AOVS !!!!!! It's still very very jagged. Please fix !!!!

Message 12 of 12
403504414
in reply to: ben.fischler

The built-in camera blur of ae will have aliasing, but if you use the blur plug-in, there will be no aliasing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report