Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

GPU rendering fails - Arnold

6 REPLIES 6
Reply
Message 1 of 7
mda2E8XF
541 Views, 6 Replies

GPU rendering fails - Arnold

[c4dtoa] 00:00:00 3543MB ERROR | [gpu] an error happened during GPU context setup : Unknown error (Details: Function "_rtBufferCreate" caught exception: Encountered a rtcore error: m_api.deviceContextCreateForCUDA( context, properties, devctx ) returned (2): Invalid device context)


C4D R21.
Latest version of Arnold - downloaded today. 3x 1070To GPUs, latest drivers.

CPU renders as expected, GPU fails...


Any recommendations?

Tags (1)
Labels (1)
  • gpu
6 REPLIES 6
Message 2 of 7
thiago.ize
in reply to: mda2E8XF

Can you post the complete log using at least info level verbosity? https://docs.arnoldrenderer.com/display/A5AFCUG/Log

This is helpful in particular because it will let us make sure you really are using the latest versions. Sometimes driver or arnold installs can go bad and the older version is still used. It might also include other useful info.

Message 3 of 7
mda2E8XF
in reply to: thiago.ize

This is the log from an IPR session - just starting the IPR on, gettting the failure and stopping the IPR. If you need anything else, just let me know:

arnold_log_debug.txt

One thing I note: It reports the system as Windows 8 - but I'm running Windows 10.

Message 4 of 7
thiago.ize
in reply to: mda2E8XF

It does look like you are indeed running the latest versions. I do not know why this nvidia Optix error is occurring. I'm trying to see if I can get more information from nvidia why they report this error. In the meantime, some guesses are:

  • Bad driver. Try installing the previous version?
  • Multi-GPUs are confusing things. Try temporarily removing two of your GPUs.
Message 5 of 7
thiago.ize
in reply to: mda2E8XF

This could be the driver being in a bad state. Does rebooting help? What about reinstalling the driver or even installing the previous driver version?

Message 6 of 7
Keith_Morley
in reply to: mda2E8XF

Is this the first time you have tried rendering on GPU with this machine? If not, what was the last working configuration on this machine for Arnold GPU rendering (driver, gpus, arnold version etc)?

Message 7 of 7
mda2E8XF
in reply to: mda2E8XF

Keith - and Thiago,
Thanks for your responses. Thiago, apologies - not realising you were staff I raised this with Stephen in supports as well! Keith - yes it is first time for Arnold on this machine.

Bottom line: I can't get GPU to work at all on this machine - which is pretty much end of life, I admit (i7 4930k). CPU mode is fine - and Redshift is fine on the GPUs (3x 1070 Ti's) . Drivers have been cleaned and updated - various versions tried, including the latest (461.40) - all with no joy. I think I'll have to leave it here for the moment; I simply don't have time to troubleshoot it, but I do appreciate your responses.

When I have a new workstation - shortly, I may try again.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums