Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Getting rid of noise from indirect diffuse

Message 1 of 5
184 Views, 4 Replies

Getting rid of noise from indirect diffuse

I am trying to render an exhibit concept that uses a room with a transparent cylinder in the center and a point light the moves through it vertically to cast shadows on the walls. I keep getting a lot of noise in the indirect diffuse no matter what I tweak, from light samples to Arnold settings. How do I get rid of the noise? 

Message 2 of 5
in reply to: elik

Do you have an example scene to look at?

Message 3 of 5
in reply to: elik

Hi, can you post some images with render settings so that we can get a better idea of where the noise is coming from? If it is indirect_diffuse noise then increasing the number of diffuse samples will reduce the noise. Be careful as increasing this value can increase render times substantially. There are tutorials on removing noise here:


Also, if you are not already using them, there are the denoising imagers and the Arnold Denoiser.

Lee Griggs
Arnold rendering specialist
Message 4 of 5
in reply to: elik

In my tests I've found that having higher AA samples, low Diffuse and higher strength settings with Noice works well on interiors. I'm on a Mac so can't use Optix.


For example:

2000x2000px scene


2 Lights (1 Quad 4 Samples, 1 Direct 3 Samples)


Settings #1

AA 3

Diffuse 4

Diffuse Ray Depth 6

Adaptive Samples Max 6

Threshold 0.35


Noice Variance: 0.25

Search Radius: 9

Render Time: 1h:49m


Settings #2

AA 6

Diffuse 2

Diffuse Ray 6

No adaptive


Noice Variance: 0.6

Search Radius 16


Render time: 54 minutes


Going the higher AA and low diffuse route nearly halved the render time. I think it works better this way because Noice has more AA samples to work with so you don't get the blotchy denoised look. Lowering the AA speeds up the render but the de-noisinig isn't good, very patchy. Increasing the Diffuse skyrockets the render time.



Message 5 of 5
in reply to: mckenzie2VER2



Many thanks. I'll try these settings. One thing that seemed to help a lot was turning on and reducing the Diffuse Clamping between 1-4

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report