Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Freeze IPR render AiNodeDestroy

Message 1 of 11
447 Views, 10 Replies

Freeze IPR render AiNodeDestroy

Hi, think I have a problem with AiNodeDestory. It's comes from Object masks I've made. But I really want to use those masks, and can't find a solution for it.

The message in console is:

cannot destroy node "/Name/Name_122" while rendering; ignoring call to AiNodeDestroy

Tags (3)
Labels (3)
Message 2 of 11
in reply to: JHåland

What's the problem? Is it "IPR freezes when you do something that triggers a call to AiNodeDestroy" ?

Can you provide a scene that reproduces the problem?

// Stephen Blair
// Arnold Renderer Support
Message 3 of 11
in reply to: Stephen.Blair

I can see if I can make a simple version

Message 4 of 11
in reply to: Stephen.Blair

hmm, sorry for not coming back to you earlier, life happen. While trying to create a simple version I think I stumbled upon the problem. I think it is a Bevel deformer that crashed the scene. Really strange. I guess I changed that a bit, didn't more about it, and then tried to add more details in the material that is connected to the mesh. I can't share the file sadly, and I can't recreate the problem on my Mac. But seems to be the problem if I go back to an old scene with the bevel deformer still on.

Message 5 of 11
in reply to: Stephen.Blair

Hi again, it seemed this is a occurring problem when I use deformers.
I also use ACES. I got the same problem in another scene and this I can share.
Download here:

Open file
Start the IPR
Open the material and try to do something in the shader network, like change the base weight, and it freezes.

Turn of IPR and the deformer and it works as expected.

I use Windows 10, Cinema 4D 20.059 on a AMD Ryzen Threadripper 3970X

Message 6 of 11

Thanks for the scene, unfortunately I haven't been able to reproduce it so far.

Does it hang or crash for you all the time or randomly? There are no textures in the scene, right? (I just fixed a hang caused by textures in C4DtoA 3.3.3) What's your C4DtoA version, btw?

I'm also noticing that you have an Arnold denoiser imager in the scene. I wonder if removing the denoiser makes any difference.

Message 7 of 11
in reply to: JHåland

It crashes consequential if the deformer is activated in the scene.

I’ve simplified the scene as mush as possible to check if the problem still happens.

I have tried to turn of the imager and it still happens. I can try to update to 3.3.3

Message 8 of 11
in reply to: JHåland

hey! seems 3.3.3 helped! I’ll test different scenes that this has occurred

Message 9 of 11

Glad to hear that! Just let me know if you still find any issues in 3.3.3.

Message 10 of 11

Jupp seem to have solved the problem in both scenes 🙂 Have a good weekend

Message 11 of 11

Awesome, thank you!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report