Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cutout Opacity and Facing Ratio problem with transmission scattering

8 REPLIES 8
Reply
Message 1 of 9
ethanberkey
288 Views, 8 Replies

Cutout Opacity and Facing Ratio problem with transmission scattering

I've been trying to create an atmosphere for a planet in c4dtoa and have gone from dead end to dead end on my goal of feathering out the atmosphere instead of having a harsh unrealistic edge, as the tutorial on the documentation shows.

My latest approach *should* work, but now I'm dealing with a problem of trying to use cutout opacity as a shader "opacity mask". The goal is to use a facing ratio to feather the shader out on the edges, but as you can see, the transmission scattering DOES NOT LIKE that. To illustrate my problem, I've simply connected a RGB ramp to the Opacity Cutout and turned the transmission to 0.5. You can see the result: the shader fades the opacity part of the shader, but the transmission has a harsh stop. Moving the ramp changes the fade on the shaders opacity, but the transmission only seems to want a 1 or 0 as it harshly stops. Btw I have tried this with Opaque both ticked and unticked and I get the same results.

I'm wondering is there another way to fade the shader out as a whole instead of the gimmick cutout opacity? Here's a link to the tutorial I am trying to follow, except its in nuke which apparently has a real Opacity mask...
(https://drive.google.com/file/d/1vpvFwhwDqX1Je0zhzAKDM9bY_NOKbPny/view)

 

Screenshot 2023-11-14 234806.pngScreenshot 2023-11-14 234846.pngScreenshot 2023-11-14 234906.png


8 REPLIES 8
Message 2 of 9
ethanberkey
in reply to: ethanberkey

Here is to further illustrate the problem I'm having. Here's a comparison between transmission on and off with Cutout opacity coming from a facing ratio and range (range just to have more control over fade).

 

Facing Ratio > Range > Cutout Opacity
far3.png

 

Transmission 0, Color 1
The shader fades out on the edges (Alpha fade)

far2.png

 

Transmission 1, Color Auto Disabled (0)
Edges seem to begin to fade but then don't. The cutout opacity doesn't have an effect.

far1.png

I'm looking for an option to have an overall fadeout. Is this achievable with a different method of controlling a shaders transparency?

Other render engines have a "Overall Fadeout" option, like Redshift for example. Also Arnold for Maya and Houdini seem to be capable of doing this. What am I missing? Or is this Arnold missing something and this feature needs to be added yet? I'm afraid even if this did work the way I want it to with the cutout opacity, it will still not give me what I'm looking for because I do not want to cut geometry out, I want to control the shaders opacity in general. How do I do that?

Appreciate any discussion or feedback.

Message 3 of 9
lee_griggs
in reply to: ethanberkey

I had a quick go with the facing_ratio -> transmission_weight and opacity. Setting specular_ior to 1 helped. Try importing this .ass shader.

lee_griggs_0-1700139107251.png

Alpha channel:

lee_griggs_1-1700139155107.png

 

 

 

Do you have a link to this Overall Fadeout option? Are you referring to this?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 4 of 9
ethanberkey
in reply to: lee_griggs

Hello Lee! Thanks for your response. Was there a reason you did this in Maya? I'm using C4D. In C4DtoA we don't have an "Opacity" channel. We have a "Cutout opacity" channel that seems to behave differently than the Opacity channel in Maya or Houdini. Cutting out geometry of the mesh instead of actually controlling the opacity of the material. And with that, the scattering as I showed doesn't fade with the cutout geometry, when for example just using a simple material without scattering will fade out properly. I can't import your material by the way.

It looks like you're multiplying a color onto the facing ratio and using that as the color of the transmission, which would explain why your alpha channel doesn't fade out, but the material seems to fadeout to black in your render view. My goal is to have an alpha fade not color fade.

My IOR is also set to 1, but I am looking for the option to use scattering because it renders volumetrics which is great if I were to add clouds at the right depth I could achieve shadow pillars coming from the clouds for example. I'm just confused why everything works with the cutout opacity - it dissolves according to the facing ratio - except for the scattering which doesn't behave correctly.

I've been trying to follow a tutorial as best as I can that was made in Houdini and transfer over the method as best as possible to C4D. Could you take a look at page 27 to see this person's method in Houdini and how could I match this in C4DtoA? His render is on page 28, that is what I'm trying to achieve. It's a very simple tutorial but I can't get it to work. (https://drive.google.com/file/d/1vpvFwhwDqX1Je0zhzAKDM9bY_NOKbPny/view)

Also I have attached an example project file. Please set the Transmission to 1 and then to 0 and that will show you my problem. I'm also wondering why there are light leaks in the mesh when transmission is set to 0?

Thanks,
Ethan

Message 5 of 9
lee_griggs
in reply to: ethanberkey

>I can't import your material by the way.

 

Why not? What happens?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 6 of 9
ethanberkey
in reply to: lee_griggs

It imports, but doesn't come through properly. Probably because you set it up in Maya?

Screenshot 2023-11-17 060917.png

Message 7 of 9
lee_griggs
in reply to: ethanberkey

Just replace the file with an Arnold image shader.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 8 of 9
ethanberkey
in reply to: ethanberkey

I don't know how to do that. None of your values came through. The nodes are wrong. I can't just replace the Image Shader and have it work.

Message 9 of 9
ethanberkey
in reply to: lee_griggs

Hmm I also just followed this tutorial in Houdini and am experiencing the same exact problem I was in Cinema 4D. This must be a bug in the latest version of Arnold??

https://help.autodesk.com/view/ARNOL/ENU/?guid=arnold_for_houdini_rendering_ah_How_to_Render_a_Plane...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums