Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Color Management Problem

8 REPLIES 8
Reply
Message 1 of 9
HJ_H
342 Views, 8 Replies

Color Management Problem

Hi there,

 

hope anybody can help. I have a Problem with the Color Management in C4DtoA or more in C4D itself. I set C4D to Linear Workflow (Screenshot_01 ). I shaded the Character and it looked all good (Screenshot_02). Now i take the Model with Materials into other Scenes for Animation and then at some point it just destroys my Materials (Screenshot_03). In some scenes the Materials are working and in some not. All Setting are the same. Does anybody knows about the issue and can help?

 

Cheers

Labels (1)
8 REPLIES 8
Message 2 of 9
peter_horvath
in reply to: HJ_H

What's you Cinema 4D version (I assume it's not Cinema 4D 2023, which has a native OCIO support) and C4DtoA version?

 

> I take the Model with Materials into other Scenes

 

Does that mean you copy & paste the model? Or loading via Arnold Procedural?

 

at some point it just destroys my Materials

 

You mean like first it renders fine, and then just suddenly becomes wrong? Or you close Cinema 4D and it renders wrong next time you open the scene?


How difficult is it to reproduce? Can you send me a scene which is failing?


// Peter Horvath
// C4DtoA developer
Message 3 of 9
HJ_H
in reply to: peter_horvath

Hi Peter,

 

thanks for the fast reply. I am using Cinema 4D r.26 and C4DtoA 4.3.0.

 

First i just copy & pasted the Character from one Project to the other. Then i started to merge the file of the final character into the scene with the animation data to retarget.

 

I can reproduce it pretty easy, but don´t see the point. If i take my final character and just delete one object, Arnold starts to convert Textures into .tx files again. Then some Textures are off and the Materials look different. (i think its 2 tx-files which cause the problem). But i can´t figure out why. If i render the character fully and don´t touch anything from the first file, everything is fine. It also happens, if i apply certain materials to other objects.

 

In the link you find one part of the character, where the Materials are not working anymore. I would like to send you a file with the same part renders correctly, but i can´t delete parts from the character without causing that problem.

 

https://drive.google.com/drive/folders/1hTxrWswUS4gpd9f8oC7DbV6gCpv4wjah?usp=share_link 

 

Do you see any mistake i am doing?

 

Regards,

Jakob

Message 4 of 9
peter_horvath
in reply to: HJ_H

View transform in your scene is set to RED Log3G10, which is quite unusual. Is that correct?

peter_horvath_0-1668788912629.png

 


// Peter Horvath
// C4DtoA developer
Message 5 of 9
HJ_H
in reply to: peter_horvath

Hi, 

 

yes, I am working with RED Footage. In the IPR I switch then to rgb preview and render it out in REDLog for Comp. That’s actually a pretty cool workflow with Arnold 🙂 

Does it render on your machine also in wrong colors? 

BR, Jakob

Message 6 of 9
peter_horvath
in reply to: HJ_H

This is what I've got, when rendering your scene out-of-the-box. Without a reference it's hard to tell whether it's good or wrong. Renders the same with tx files turned off.

 


// Peter Horvath
// C4DtoA developer
Message 7 of 9
HJ_H
in reply to: HJ_H

Hey,

 

i figured it out. Arnold interpreted two textures randomly different. Tagging them as sRGB solved the issue. Thank you for help.

 

BR, Jakob

Message 8 of 9
peter_horvath
in reply to: HJ_H


i figured it out. Arnold interpreted two textures randomly different. Tagging them as sRGB solved the issue. Thank you for help.

I don't like the word "random" in this. 🙂 The color space should not randomly change if you copy the material or remove objects. If it happens again and you have more insight when or how, please let me know.


// Peter Horvath
// C4DtoA developer
Message 9 of 9
HJ_H
in reply to: peter_horvath

Hi,

 

yeah, i also don´t like random things 🙂 But i also didn´t use Arnold for 2 years. With Redhshift and Cinema4D everything got pretty simple. So yeah... i could have thought about applying each texture its colorspace.

 

Cheers

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report